Consistently get CGContextGetType: invalid context Errors in Terminal

RESOLVED FIXED

Status

()

Core
Graphics
P2
normal
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: gkw, Assigned: vlad)

Tracking

unspecified
x86
Mac OS X
Points:
---
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b5pre) Gecko/2008031704 Minefield/3.0b5pre

Similar to bug 422259, I now get

firefox-bin[612] <Error>: CGContextGetType: invalid context

errors in Terminal, and occasional messages in

FG: isPreferred(multipart/x-mixed-replace,[object Object])
FG: _shouldIntercept(multipart/x-mixed-replace)

Related to the cairo upgrade?
This is the bug that won't die.  I keep playing whackamole with it!  Though finally, the issue is that we're trying to draw with a 0x0 source surface, which doesn't have an associated cgContext... so the cgContext is NULL.

I've got a patch that I'll push into cairo, and will try to get it into mozilla as well before b5.
Assignee: joshmoz → vladimir
Component: Widget: Cocoa → GFX: Thebes
Flags: blocking1.9+
Priority: -- → P2
Created attachment 310287 [details] [diff] [review]
fix this

This is already in upstream cairo, but I want to grab it separately from doing another cairo uplift..
Attachment #310287 - Flags: review?(pavlov)
Duplicate of this bug: 423455

Comment 4

10 years ago
The bug is still active as of this morning. I got another 1000 or so error messages on my Mac console. Im using the nightly build.  

Updated

10 years ago
Attachment #310287 - Flags: review?(pavlov) → review+
Checked in.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.