Closed Bug 423528 Opened 12 years ago Closed 12 years ago

Huge dropdowns near back and forward buttons

Categories

(Toolkit :: Toolbars and Toolbar Customization, defect, major)

x86
Linux
defect
Not set
major

Tracking

()

VERIFIED FIXED

People

(Reporter: mozilla_bugs, Assigned: neil)

References

Details

(Keywords: regression)

Attachments

(5 files, 1 obsolete file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.9b5pre) Gecko/2008031701 SeaMonkey/2.0a1pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.9b5pre) Gecko/2008031701 SeaMonkey/2.0a1pre

In the builds since a few days ago, the back and forward buttons (and other buttons in toolbars with an attached drop-down menu) are sporting the huge ugly dropdowns near them. a screenshot comes up promptly. I can't believe they are supposed to be there...

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
No, this can't be serious, it must be a bug...
see comment 29 in bug 416868
Blocks: 416868
Severity: normal → major
Status: UNCONFIRMED → NEW
Component: XP Apps: GUI Features → Widget: Gtk
Ever confirmed: true
Product: Mozilla Application Suite → Core
QA Contact: guifeatures → gtk
Version: unspecified → Trunk
This seems to be a platform/toolkit regression that isn't directly visible in Firefox but easily in Thunderbird and SeaMonkey trunk builds. It should probably be included in tracking 1.9 problems/regressions.
Flags: blocking1.9?
Keywords: regression
-'ing this until we know if this is indeed a platform/toolkit regression.  Please re-nom once we have more information and if needed.
Flags: wanted1.9.0.x+
Flags: blocking1.9?
Flags: blocking1.9-
Attached file Example extension
Simple example of impending pain for extensions. This is just bog-standard XUL (it's Ted's extension creation wizard, with |type="menu-button"| added to the toolbarbutton).

STR:
1. Install Ubuntu, get tired of the orange theme, switch to Clearlooks.
2. Install this extension in Firefox (or Thunderbird, but we already know how unstyled dropmarkers look there), restart, customize toolbars and drag "Your Toolbar Button" onto the toolbar.
3. Enjoy the site of a monster dropmarker next to the button.
Screenshot of the monster dropmarker, in case "install an OS" is too big a step to reproduce.
Damon: I presume comment 5 and comment 6 are enough to qualify it as "a platform/toolkit regression"? Tbird and SeaMonkey can hack around it easy enough (Firefox is already full of hacks for it, see most instances of "12px" in browser/themes/gnomestripe) but none of that is going to help extension developers who think that exactly following the directions on devmo and doing something that looks okay on Windows and Mac should produce something that doesn't look silly on Linux.
Flags: blocking1.9- → blocking1.9?
I'm guessing its because we don't limit the size on the widget end, nor should we since its a general-purpose arrow.

There has to be a global CSS rule for this somewhere where we can set max-width: 12px;
Attached patch PatchSplinter Review
This should work, haven't tested it against the extension yet.
Assignee: nobody → ventnor.bugzilla
Status: NEW → ASSIGNED
Attachment #311985 - Flags: review?(rflint)
Yep, works wonderfully.

15px looks like the sweet spot on my computer.
Setting a max-width is not the right fix

The problem is caused by the inner .dropdown-icon

Adding a ".dropdown-icon { display: none; }" in the right place solves the bug.

I'd like to have the opinion of some of you: is putting this rule risky or not ? I think it shouldn't affect anything else, since every type dropdown is native themed in gnomestripe, but I'd like a confirmation.
How does that fix the bug? I can't find any mention of "dropdown-icon" on MXR.
With dom inspector I noticed that the inner image (which is supposed to contain the arrow when the dropdown isn't native) has a .dropdown-icon class.
Sorry, it's "dropmarker-icon"
If the patch gets reviewed, we can take the fix via approval, but wouldn't block..
Flags: blocking1.9? → blocking1.9-
Attached patch Avoid huge dropdown arrows v1 (obsolete) — Splinter Review
Attachment #313493 - Flags: review?
Attachment #313493 - Flags: review? → review?(rflint)
Attachment #311985 - Flags: review?(rflint)
Comment on attachment 313493 [details] [diff] [review]
Avoid huge dropdown arrows v1

Drive-by nit: incorrect indentation, should be 2 spaces
Attached patch PatchSplinter Review
I think the problem lies with -moz-image-region.
Attachment #313619 - Flags: review?(rflint)
Neil, your patch also solves the bug for me; this image region was causing the arrow to be big, and I was merely hiding it.
Attachment #313493 - Attachment is obsolete: true
Attachment #313493 - Flags: review?(rflint)
Attachment #313619 - Flags: review?(rflint) → review+
Assignee: ventnor.bugzilla → neil
Status: ASSIGNED → NEW
Component: Widget: Gtk → Toolbars and Toolbar Customization
Product: Core → Toolkit
QA Contact: gtk → toolbars
Comment on attachment 313619 [details] [diff] [review]
Patch

Theme-only change that fixes a glaring issue on non-Firefox toolkit users. This isn't seen on Firefox due to some hardcoded max sizes, but without those max sizes, this would be visible.
Attachment #313619 - Flags: approval1.9?
Comment on attachment 313619 [details] [diff] [review]
Patch

a1.9=beltzner
Attachment #313619 - Flags: approval1.9? → approval1.9+
Fix checked in.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Verified FIXED, Seamonkey 2008042101 build.
Status: RESOLVED → VERIFIED
Flags: wanted1.9.0.x+
You need to log in before you can comment on or make changes to this bug.