On Firefox start page on Google preferences, the interface language selected (english) changes suddenly to unknown language

RESOLVED INCOMPLETE

Status

()

Firefox
Preferences
--
major
RESOLVED INCOMPLETE
10 years ago
7 years ago

People

(Reporter: Paula, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12

At first I thought that by mistake I unknowingly changed the interface language under Google global preferences.  Since I was unable to change it back to the English language, due to the fact that it was all in a language which seems to be Japanese, I proceed to uninstall and reinstall Firefox from my computer. When I first reopen Firefox everything seemed to be OK, I was back in the English language. However, after three hours of using my pc, while I was browsing results on Google, suddenly it all went back to this unknown, to me at least, language. Consequently, when viewing my search results on Google instead of reading under each result the options “cached” and “similar pages” all I see is what seems to be Japanese or Chinese characters. Similarly to what was reported on bug ID 401803, on one occasion all I could see where ???? characters (however mine is a pc, not a Mac).

Reproducible: Always

Steps to Reproduce:
1.uninstall/reinstall Firefox
2.open firefox start page
3.start using Google Search
Actual Results:  
Suddenly the language interface changes from english to something with characters like chinese or japanese. On one occasion, it changed to ??? marks.

Expected Results:  
keep the selected language interface, i.e. english

about:buildconfig

Build platform
target
i586-pc-msvc

Build tools
Compiler 	Version 	Compiler flags
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TC -nologo -W3 -Gy -Fd$(PDBFILE)
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TP -nologo -W3 -Gy -Fd$(PDBFILE)

Configure arguments
--enable-application=browser --enable-update-channel=release --enable-official-branding --enable-optimize --disable-debug --disable-tests --enable-static --disable-shared --enable-svg --enable-canvas --enable-update-packaging
(Reporter)

Comment 1

10 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12)
> Gecko/20080201 Firefox/2.0.0.12
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12)
> Gecko/20080201 Firefox/2.0.0.12
> 
> At first I thought that by mistake I unknowingly changed the interface language
> under Google global preferences.  Since I was unable to change it back to the
> English language, due to the fact that it was all in a language which seems to
> be Japanese, I proceed to uninstall and reinstall Firefox from my computer.
> When I first reopen Firefox everything seemed to be OK, I was back in the
> English language. However, after three hours of using my pc, while I was
> browsing results on Google, suddenly it all went back to this unknown, to me at
> least, language. Consequently, when viewing my search results on Google instead
> of reading under each result the options “cached” and “similar pages”
> all I see is what seems to be Japanese or Chinese characters. Similarly to what
> was reported on bug ID 401803, on one occasion all I could see where ????
> characters (however mine is a pc, not a Mac).
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1.uninstall/reinstall Firefox
> 2.open firefox start page
> 3.start using Google Search
> Actual Results:  
> Suddenly the language interface changes from english to something with
> characters like chinese or japanese. On one occasion, it changed to ??? marks.
> 
> Expected Results:  
> keep the selected language interface, i.e. english
> 
> about:buildconfig
> 
> Build platform
> target
> i586-pc-msvc
> 
> Build tools
> Compiler        Version         Compiler flags
> $(CYGWIN_WRAPPER) cl    12.00.8804      -TC -nologo -W3 -Gy -Fd$(PDBFILE)
> $(CYGWIN_WRAPPER) cl    12.00.8804      -TP -nologo -W3 -Gy -Fd$(PDBFILE)
> 
> Configure arguments
> --enable-application=browser --enable-update-channel=release
> --enable-official-branding --enable-optimize --disable-debug --disable-tests
> --enable-static --disable-shared --enable-svg --enable-canvas
> --enable-update-packaging
> 

Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 401803
(Reporter)

Updated

10 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 2

10 years ago
This bug is not a duplicate of bug 401803.
Problem appeared with Firefox/2.0.0.12.
(Reporter)

Comment 3

10 years ago
I uninstalled Firefox 2.0.0.12 and installed a previous version (2.0.0.11) hoping to solve the problem. However, it did not, same thing happens. To be more specific I discovered that when I open Firefox, my home page is the one that changes randomly, that is the reason why the language I selected under “Preferences” on the Firefox start page (Google) also switches. Even though I went to Tools/options/Main/startup/homepage and made sure it was set to http://en-US.start2.mozilla.com/firefox?client=firefox-a&rls=org.mozilla:en-US:official when I open firefox the start page url reads http://www.google.es/firefox?client=firefox-a&rls=org.mozilla:en-US:official, i.e. Spain instead of US. Yesterday when I open Firefox, it was set to German. I tried cut/paste the English US URL on the address bar but it does not take it. So every day is a different home page with me having nothing to do with it. I have 2 computers at home, both run Firefox and although the problem begun in only one computer now the other one is experiencing the same problem. Nobody out there having the same issue?  

Comment 4

8 years ago
yes.  Deutsh most common.

Comment 5

7 years ago
Reporter -> Are you still experiencing this issue with the latest version of Firefox 3.6.15? Does the issue occur with the latest nightly? http://nightly.mozilla.org/
Version: unspecified → 2.0 Branch

Comment 6

7 years ago
Closing bug as Incomplete - if you are still experiencing this issue or have more information to provide feel free to post back here and we can re-open the bug. You can also get assistance by visiting the Firefox help site -> http://support.mozilla.com/en-US/kb/Ask+a+question
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago7 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.