If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Sunbird and Thunderbird pages shouldn't have links to "themes" page

VERIFIED FIXED in 3.2.1

Status

addons.mozilla.org Graveyard
Public Pages
VERIFIED FIXED
10 years ago
2 years ago

People

(Reporter: stephend, Assigned: wenzel)

Tracking

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

10 years ago
Summary: "View All" link in Sunbird themes misses its type and category

1. Load https://preview.addons.mozilla.org/en-US/sunbird/browse/type:2
2. Click "See All"

Expected Results:

https://preview.addons.mozilla.org/en-US/sunbird/browse/type:2/cat:all?sort=name loads

Actual Results:

https://preview.addons.mozilla.org/en-US/sunbird/browse/type:/cat:?sort=name loads
(Reporter)

Updated

10 years ago
Summary: "View All" link in Sunbird themes misses its type and category → "See All" link in Sunbird themes misses its type and category
Target Milestone: --- → 3.x (triaged)
(Reporter)

Comment 1

10 years ago
Can we sneak this in to 3.21?
(Assignee)

Comment 2

10 years ago
Hm. That's because themes are not a valid hybrid category for Sunbird (i.e. it's unlinked to an "appearance extension" category). This page should probably not even be linked to anywhere.
(Assignee)

Comment 3

10 years ago
We decided on fixing this by removing the "I want to find..." list for Sunbird for now, because due to the small number of categories for Sunbird it doesn't provide much additional value there at the moment.
Target Milestone: 3.x (triaged) → 3.2.1
(Assignee)

Updated

10 years ago
Duplicate of this bug: 423629
Chris could you post a quick fix for these?
Assignee: nobody → cpollett

Comment 6

10 years ago
Created attachment 313766 [details] [diff] [review]
removes the I am looking for element for Sunbird and Thunderbird as fwenzel suggested

The proposed patch would also fix Bug 423620
Attachment #313766 - Flags: review?

Updated

10 years ago
Attachment #313766 - Flags: review? → review+

Comment 7

10 years ago
Thanks for the review clouserw!
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

10 years ago
Hrm; I checked on Khan, which should have the latest fixes, and still see the "I want to..." box:

http://img146.imageshack.us/my.php?image=picture6ve8.png

Why is this?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

10 years ago
Assignee: cpollett → fwenzel
Status: REOPENED → NEW
(Assignee)

Updated

10 years ago
Duplicate of this bug: 423620
(Assignee)

Updated

10 years ago
Summary: "See All" link in Sunbird themes misses its type and category → Sunbird and Thunderbird pages shouldn't have links to "themes" page
(Assignee)

Comment 10

10 years ago
Created attachment 314650 [details] [diff] [review]
Removing pitch from landing pages and globally from sidebar for Sb and Tb

Can you review again, Wil? This patch removes the "pitch" box globally from the sidebar (since it was still present on the recommended page also), and it removes it from the landing pages as well.
Attachment #313766 - Attachment is obsolete: true
Attachment #314650 - Flags: review?(clouserw)

Updated

10 years ago
Attachment #314650 - Flags: review?(clouserw) → review+
(Assignee)

Comment 11

10 years ago
Thanks! Committed to r12123.
Status: NEW → RESOLVED
Last Resolved: 10 years ago10 years ago
Keywords: push-needed
Resolution: --- → FIXED
(Reporter)

Comment 12

10 years ago
Verified FIXED using https://remora-reskin.stage.mozilla.com/en-US/sunbird/ and https://remora-reskin.stage.mozilla.com/en-US/thunderbird/, and their respective landing pages.
Status: RESOLVED → VERIFIED
Keywords: push-needed
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.