Last Comment Bug 423674 - Update to breakpad revision 250
: Update to breakpad revision 250
Status: RESOLVED FIXED
:
Product: Toolkit
Classification: Components
Component: Breakpad Integration (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Ted Mielczarek [:ted.mielczarek]
:
:
Mentors:
Depends on: 419346
Blocks: 391361
  Show dependency treegraph
 
Reported: 2008-03-18 09:18 PDT by Ted Mielczarek [:ted.mielczarek]
Modified: 2008-03-20 05:12 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
update from revision 240 to 250 (355.78 KB, patch)
2008-03-18 09:18 PDT, Ted Mielczarek [:ted.mielczarek]
no flags Details | Diff | Splinter Review
update from r240 to r250, without the windows client changes (342.24 KB, patch)
2008-03-18 18:16 PDT, Ted Mielczarek [:ted.mielczarek]
sayrer: review+
shaver: approval1.9+
Details | Diff | Splinter Review

Description Ted Mielczarek [:ted.mielczarek] 2008-03-18 09:18:30 PDT
Created attachment 310270 [details] [diff] [review]
update from revision 240 to 250

I'd like to get Alfred's Solaris fixes in for b5 so they can ship Firefox with Breakpad there. This patch contains a lot of stuff, but most of it is in the processor code, and thus not really relevant to us. There are a few things in the Windows handler code, due to the out of process minidump writing landing, I'm taking a look at those now, and I'll spin some try server builds with this patch to be sure.
Comment 1 Matthias Versen [:Matti] 2008-03-18 16:30:43 PDT
Is there a changelog somewhere ?
Comment 2 Ted Mielczarek [:ted.mielczarek] 2008-03-18 17:57:58 PDT
You can see the SVN revision log here:
http://code.google.com/p/google-breakpad/source/list
Comment 3 Ted Mielczarek [:ted.mielczarek] 2008-03-18 18:16:02 PDT
Created attachment 310388 [details] [diff] [review]
update from r240 to r250, without the windows client changes
Comment 4 Ted Mielczarek [:ted.mielczarek] 2008-03-18 18:23:08 PDT
Right, so, I decided not to import the windows client bits, to avoid any possible risk there. The only thing this patch touches that we actually build is src/google_breakpad/common/minidump_format.h, and that's just a refactoring of the contents of the file, no actual content changes.
Comment 5 Robert Sayre 2008-03-18 18:39:11 PDT
Comment on attachment 310388 [details] [diff] [review]
update from r240 to r250, without the windows client changes

rs=sayrer, mostly npotb
Comment 6 Ted Mielczarek [:ted.mielczarek] 2008-03-18 18:41:09 PDT
Comment on attachment 310388 [details] [diff] [review]
update from r240 to r250, without the windows client changes

This patch is almost entirely NPOTB, and the part that is part of the build is just splitting one large header into several smaller header files. It's a prerequisite for Solaris breakpad support.
Comment 7 Mike Shaver (:shaver -- probably not reading bugmail closely) 2008-03-18 18:45:57 PDT
Comment on attachment 310388 [details] [diff] [review]
update from r240 to r250, without the windows client changes

the sweet sound
of patch-set approval
comin' down in a 
not quite freeze

(a=shaver)
Comment 8 Ted Mielczarek [:ted.mielczarek] 2008-03-18 18:48:54 PDT
Checked in.

Note You need to log in before you can comment on or make changes to this bug.