Proto Theme landing regressed sunspider

RESOLVED FIXED in Firefox 3 beta5

Status

()

Firefox
Theme
P1
normal
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Robert Sayre, Assigned: Gavin)

Tracking

Trunk
Firefox 3 beta5
x86
Mac OS X
Points:
---
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
1-3% regression shown on mac tinderboxen.
(Reporter)

Updated

10 years ago
Component: General → Theme
Product: Core → Firefox
QA Contact: general → theme
Version: unspecified → Trunk
(Reporter)

Comment 1

10 years ago
Are the text decorations in the status bar new? That's probably it. That text is very performance sensitive. We shouldn't be applying decorations to it.

Comment 2

10 years ago
yes, they are new.
Ryan, can we get that backed out for Beta 5? I can't remember if there's a specific bug on the text in the status bar, but if not, we can file a follow up and deal with it after.
Assignee: nobody → rflint
Flags: blocking-firefox3+
Priority: -- → P1
No separate bug, no, but the changes in question are here:

https://bugzilla.mozilla.org/attachment.cgi?id=309985&action=diff#mozilla/browser/themes/pinstripe/browser/browser.css_sec4

and here:

https://bugzilla.mozilla.org/attachment.cgi?id=309985&action=diff#mozilla/browser/themes/pinstripe/browser/browser.xml_sec2
Assignee: rflint → gavin.sharp
Priority: P1 → --
Created attachment 310364 [details] [diff] [review]
revert statusbar XBL changes

This patch had no effect locally, but I can't reproduce the regression locally either. Backing out the patch for bug 423361 entirely didn't show a significant difference.

I tried landing this to see what the mac Talos machines will say.
That seems to have fixed it.

Ryan, can you confirm that my backout didn't miss anything?

Beltzner, do we want a followup on re-enabling this styling in some way that doesn't regress performance?

Comment 7

10 years ago
I don't think a new bug is needed.  We just need to mention in bug 414728 that the initial attempt did in fact regress perf.
(In reply to comment #6)
> Ryan, can you confirm that my backout didn't miss anything?
Looks fine to me :)

(In reply to comment #7)
> I don't think a new bug is needed.  We just need to mention in bug 414728 that
> the initial attempt did in fact regress perf.

Yeah, I didn't realize there was already a bug on it.

This is FIXED.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Priority: -- → P1
Target Milestone: --- → Firefox 3 beta5
You need to log in before you can comment on or make changes to this bug.