Closed Bug 423764 Opened 14 years ago Closed 14 years ago

Saving a page as text, download remains active forever

Categories

(Toolkit :: Downloads API, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 418961

People

(Reporter: jjreisert, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4

I keep my documentation on the web and save the doc as text format to include along with the software I distribute.

Using the most recent beta, when I save the page as text, the download manager comes up, but the progress bar never advances, and this text remains at the bottom of my Firefox window:  "One active download (Unknown time remaining)".  Regardless of all this, the file does indeed get saved.  This was not a problem in Firefox 2.0, and I'm using the same procedure as always.  The destination file(s) are NOT write protected.

Reproducible: Always

Steps to Reproduce:
1. Go to any web page
2. Save page as text
3.
Actual Results:  
The download manager comes up, but the progress bar never advances, and this text remains at the bottom of my Firefox window:  "One active download (Unknown time remaining)".

Expected Results:  
File downloaded and saved, download completes normally.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 418961
verified - this is fixed in beta 5
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.