Three fingers swipe on trackpad for History and Tabs navigation

RESOLVED DUPLICATE of bug 412486

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 412486
11 years ago
11 years ago

People

(Reporter: francois, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: http://download.mozilla.org/?product=firefox-3.0b4&os=osx&lang=en-US

The MacBook Airs and newer MacBook Pros have built-in support for multitouch finger gestures on the the trackpad. Safari uses three fingers swipe left, resp. three fingers swipe right to go back, resp. forward in history.

I suggest Firefox do the same. And even push this further:
- three fingers swipe down to go to next tab;
- three fingers swipe up to go to previous tab.

Should be easy to detect those three fingers swipe events in Firefox, and call equivalent key commands.

To go back in history, Firefox currently offers at least four ways:

- Back button on toolbar
- Shift + Scroll Down (mouse)
- Alt + Left Arrow
- Backspace

Similarly, to go forward:

- Forward button on toolbar
- Shift + Scroll Up (mouse)
- Alt + Right Arrow
- Shift + Backspace

To go to next tab, currently possible is:

- Ctrl + Page Down
- Ctrl + Tab

And to go to previous tab:

- Ctrl + Page Up
- Ctrl + Shift + Tab

Reproducible: Always
(Reporter)

Comment 1

11 years ago
Bug 412486 suggests the same, but I add tab navigation here.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 412486
You need to log in before you can comment on or make changes to this bug.