Last Comment Bug 423906 - COPYING file for Dehydra
: COPYING file for Dehydra
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Rewriting and Analysis (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: 423898
  Show dependency treegraph
 
Reported: 2008-03-19 10:40 PDT by (dormant account)
Modified: 2008-04-25 16:02 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description (dormant account) 2008-03-19 10:40:55 PDT
My plan is to just copy the GPL v2 one from the GCC tree. Is that reasonable?
Comment 1 Benjamin Smedberg [:bsmedberg] 2008-03-19 10:54:39 PDT
We're building against GCC4.3 which is GPLv3.
Comment 2 (dormant account) 2008-03-19 11:01:18 PDT
Thanks for clarifying the GCC license mess. I'll copy COPYING3 file from GCC since it's v3 now.
Comment 3 Mitchell Baker 2008-03-19 12:47:29 PDT
Taras

Just checking -- 

this is code that exists quite separately from the code we build and ship as Mozilla technology?

Is it actually required that your work be licensed under the GPL? Or is it that this seems to make sense given GCC?

Mitchell
Comment 4 Benjamin Smedberg [:bsmedberg] 2008-03-19 12:55:33 PDT
This code is separate from Mozilla.

It has to be GPLv3, because it is including headers and linking functions from GCC.
Comment 5 Mitchell Baker 2008-03-19 15:42:45 PDT
OK, thanks, that sounds pretty clear.

mitchell
Comment 6 (dormant account) 2008-04-03 12:52:29 PDT
Benjamin is suggesting that we should use GPLv2&later since we'll also be compiling against gcc 4.2
Comment 7 (dormant account) 2008-04-25 16:02:40 PDT
Pushed README, COPYING files. I would rather not pollute the source files, unless someone can provide me with a 1-2line lawyerspeak header.

Note You need to log in before you can comment on or make changes to this bug.