Glubble Family Edition Extension: JavaScript Error: "this._accountDAO is null

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
Administration
RESOLVED FIXED
10 years ago
2 years ago

People

(Reporter: Tomcat, Assigned: Ian Hayward)

Tracking

Details

(URL)

(Reporter)

Description

10 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b5pre) Gecko/2008031718 Firefox/3.0b5pre ID:2008031718

Steps to reproduce:
- Install the Gubble Family Edition https://addons.mozilla.org/en-US/firefox/addon/5881
- Click a little around on the Features of this Extension
--> JS Error

[Exception... "'[JavaScript Error: "this._accountDAO is null" {file: "file:///Users/carstenbook/Library/Application%20Support/Firefox/Profiles/hlt4i7e4.default/extensions/%7B83874588-ae10-4dbb-8dba-8301c86cb8fc%7D/components/gsGluAccountService.js" line: 427}]' when calling method: [gsIGluAccountService::getAllAccounts]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://glubble/content/userbar/gsGluUserbar.js :: anonymous :: line 189"  data: yes]

Comment 1

9 years ago
Hi everyone.
We are the extension author, and we are working on the fix for this issue.
I am trying to assign the bug to ourselves, but I can't get the right permissions for that yet.
We'll update the bug with more info once we have news ;)
Thanks for the report.

Comment 2

9 years ago
Fixed with the latest update of the add-on, on 2008-10-28
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Assignee)

Updated

9 years ago
Assignee: nobody → ian-bugzilla

Comment 3

9 years ago
The bug for the specified add-on (Glubble) was fixed today (2008-10-28), with xpi version number 2.0.1.1. The xpi update was submitted to AMO, and it is already approved.
The specific root cause of this error was a top toolbar the extension usd to add to the browser on top of the navigation toolbar. That toolbar was removed, as well as a lot of code related to it. In particular, removing that code fixed the bug ;)
Cheers.

Comment 4

9 years ago
Thank you for the quick response to this issue Glaxstar.
Component: Add-ons → Administration
QA Contact: add-ons → administration
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.