If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"Use Received Date" preference does not parse date correctly

RESOLVED DUPLICATE of bug 392774

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 392774
10 years ago
7 years ago

People

(Reporter: John Patrick, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Tunderbird 2.0.0.12 (20080213)

Greetings,

I currently use the mailnews.use_received_date TRUE option and Thunderbird correctly parses most of emails and displays the correct received date but below is the header of one email that is displayed as 12 May 2008 -- the sent date in the FUTURE -- instead of the correct Received Date of 12 Mar 2008, because Thunderbird is unable to parse the received headers.  

Can this be fixed?


Return-Path: <XXXXX-XXXX-X@usc.edu>
Delivery-Date: Wed, 12 Mar 2008 17:50:35 -0400
Received: from msg-mx5.usc.edu (msg-mx5.usc.edu [128.125.137.10])
	by mx.perfora.net (node=mxus3) with ESMTP (Nemesis)
	id 0MKofY-1JZYqC2YyX-0003VC for XXXXX@yahoo.com; Wed, 12 Mar 2008 17:50:34 -0400
Received: from listproc.usc.edu ([128.125.253.84])
 by msg-mx5.usc.edu (Sun Java System Messaging Server 6.2-7.05 (built Sep  5
 2006)) with ESMTP id <0JXN00BD10NXPZF0@msg-mx5.usc.edu> for
 XXXXXX@yahoo.com; Wed, 12 Mar 2008 14:50:21 -0700 (PDT)
Received: from listproc.usc.edu (listproc@localhost [127.0.0.1])
	by listproc.usc.edu (8.10.1/8.10.1/usc) with SMTP	id m2CLoLA06763; Wed,
 12 Mar 2008 14:50:21 -0700 (PDT)
Received: from msg-mx0.usc.edu (sjes@msg-mx0.usc.edu [128.125.137.5])
	by listproc.usc.edu (8.10.1/8.10.1/usc) with ESMTP	id m2CLoIA06720 for
 <XXXX-X@listproc.usc.edu>; Wed, 12 Mar 2008 14:50:18 -0700 (PDT)
Received: from usc.edu ([128.125.253.136])
 by msg-mx0.usc.edu (Sun Java System Messaging Server 6.2-7.05 (built Sep  5
 2006)) with ESMTP id <0JXN00MV20NUVME0@msg-mx0.usc.edu> for
 hash-l@listproc.usc.edu (ORCPT hash-l@usc.edu); Wed,
 12 Mar 2008 14:50:18 -0700 (PDT)
Received: from msg-scanner0.usc.edu
 (sjes@msg-scanner0.usc.edu [128.125.137.209])	by usc.edu (8.10.1/8.10.1/usc)
 with ESMTP	id m2CLoIL14031 for <hash-l@usc.edu>; Wed,
 12 Mar 2008 14:50:18 -0700 (PDT)
Received: from msg-mx3.usc.edu ([128.125.137.8])
 by msg-scanner0.usc.edu (Sun Java System Messaging Server 6.2-3.04 (built Jul
 15 2005)) with ESMTP id <0JXN004H90NTM8K0@msg-scanner0.usc.edu> for
 hash-l@usc.edu (ORCPT hash-l@usc.edu); Wed, 12 Mar 2008 14:50:18 -0700 (PDT)
Received: from QMTA08.emeryville.ca.mail.comcast.net
 (qmta08.emeryville.ca.mail.comcast.net [76.96.30.80])
	by msg-mx3.usc.edu (Postfix) with ESMTP id 1D92F32E75	for <XXXX-X@usc.edu>;
 Wed, 12 Mar 2008 14:50:13 -0700 (PDT)
Received: from OMTA05.emeryville.ca.mail.comcast.net ([76.96.30.43])
	by QMTA08.emeryville.ca.mail.comcast.net with comcast	id
 0Hxu1Z05c0vp7WLA80Di00; Wed, 12 Mar 2008 21:49:24 +0000
Received: from UPSTAIRS ([69.249.46.101])
	by OMTA05.emeryville.ca.mail.comcast.net with comcast	id
 0Mpx1Z0022Az9El8R00000; Wed, 12 Mar 2008 21:49:58 +0000
Date: Mon, 12 May 2008 17:48:16 -0400
From: gil jackson <XXXXXXXXXX@comcast.net>
Subject: Re: HashSpace
Sender: XXXXX-XXXX-X@usc.edu
To: gil jackson <XXXXXXXXXX@comcast.net>, XXX@gotothehash.net,
 XXXXXXX@yahoogroups.com, XXX-X@usc.edu, XXXXXXXXXXX@yahoogroups.com
Reply-to: XXXXXXXXXX@comcast.net
Message-id: <004701c8b479$e35c7930$64010a0a@UPSTAIRS>
MIME-version: 1.0
X-MIMEOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
X-Mailer: Microsoft Outlook Express 6.00.2900.3138
Content-type: multipart/alternative;
 boundary="Boundary_(ID_3tpI3J6Pm4fQhpbpB0ueVg)"
X-Priority: 3
X-MSMail-priority: Normal
Precedence: bulk
X-Authority-Analysis: v=1.0 c=1 a=p-YVpQZMAAAA:8 a=JY1opH6JAAAA:8
 a=9b-eKfyRAAAA:8 a=VZ_Fueopkpy7BSIQB1sA:9 a=sEnFw17RoPsbm25HgaP5K1l56OkA:4
 a=IPNjilUfhe8A:10 a=ao4RW71Vw8YA:10 a=JcB9aHnUDh0A:10 a=Qly16OuK8IisqGxpVmkA:9
 a=aOP0ui5IZCPAPGtSpfQA:7 a=fHTzxdU6yrwpKfY1mK85_ir0WRcA:4 a=si9q_4b84H0A:10
 a=AfD3MYMu9mQA:10
X-Listprocessor-Version: 8.1 -- ListProcessor(tm) by CREN
X-Nemesis-Spam: rulefilter
X-PhishingScore:   0
	tests= 
X-SpamScore: 6.1
	tests= DATE_IN_FUTURE_96_XX FAKE_REPLY_C HTML_MESSAGE
Envelope-To: XXXXXX@yahoo.com

Reproducible: Always

Steps to Reproduce:
1. Set mailnews.use_received_date to TRUE in the config
2. Message header provided.
3.
Actual Results:  
Display the future sent Date of "12 May 2008 17:48"

Expected Results:  
Display the received date of "12 Mar 2008 17:50"
> displayed as 12 May 2008
> Date: Mon, 12 May 2008 17:48:16 -0400

Timestamp in Date: header is used.

> Build Identifier: Tunderbird 2.0.0.12 (20080213)
> 1. Set mailnews.use_received_date to TRUE in the config

Final patch for Bug 166254 is landed trunk only. Patch landed on branch(landed to Tb 2.0.0.5), which introduced mailnews.use_received_date, is partial implementation. And, even when trunk(final implementation of Bug 166254), if IMAP, timestamp in Received: header can't be used, because FECTH of Received: header is still not executed at mail header check step (already reported bug. search bugs well, please). Received: headers are downloaded after standard mail header check. So they can be seen when mail source display.
This is similar issue to Bug 184490.

If IMAP, please search bugzilla.mozilla.org well for already opened bug via "Advanced Search".

  
Depends on: 392774
Bug 392774 & Bug 402594 were the already opened bugs for IMAP.
(Easily be found by "Advanced Search" for open bugs which has "received date" in bug summary)
Read Bug 166254 Comment #254 thru Bug 166254 Comment #256 for partial patch when branch.

Comment 3

9 years ago
No reply from John, so marking as duplicate of Bug 392774.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 392774
You need to log in before you can comment on or make changes to this bug.