If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Global inbox is missing after creating a first account which uses global inbox - No mail receiving possible then

RESOLVED FIXED in Thunderbird 3

Status

Thunderbird
Mail Window Front End
--
major
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: Thorsten, Assigned: Boying Lu)

Tracking

({regression})

Trunk
Thunderbird 3
regression
Bug Flags:
blocking-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

820 bytes, patch
neil@parkwaycc.co.uk
: review+
Bienvenu
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4
Build Identifier: Thunderbird version 3.0a1pre (2008031904)

When you start TB with a new empty profile the assistant for creating an account tries to help you to create a first email account in your new TB profile.
If you check "Use global inbox" so that new mail should be stored in the global inbox. After the assistant is finished you can see on the left side under "Local folders" only the two subfolders "Unsent" and "Trash".

It is not possible to receive mails now, allthough the email account is created probably.  You have to open the "Account settings" first. Go to "Server settings". Click on the button "Advanced.." and be sure that "Global inbox" is choosen and then click on "OK". Then the Global inbox is created and you can receive mails.



Reproducible: Always

Steps to Reproduce:
1. Create a new profile 
2. Create a new mailaccount with the assistant
3. Be sure that "Use Global inbox" is checked in the assistant
4. After the assistant is finished, only the folders "Unsent" and "Trash" are created.
Actual Results:  
Only the subfolders "Unsent" and "Trash" are created.

Expected Results:  
Also an "Inbox" should be created so that mail receiving is possible.
(Reporter)

Updated

10 years ago
Version: unspecified → Trunk

Comment 1

10 years ago
Linux too. 

When you try to get the messages:
Error: uncaught exception: [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsIMsgIncomingServer.getNewMessages]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: chrome://messenger/content/mailCommands.js :: GetNewMessages :: line 20"  data: no]

Regression from tb2, but not recent. I think I saw it a few months back already but didn't get around to filing.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Windows Vista → All
Hardware: PC → All
Flags: blocking-thunderbird3?
(Assignee)

Comment 2

9 years ago
Created attachment 323980 [details]
patch
(Assignee)

Updated

9 years ago
Attachment #323980 - Attachment is obsolete: true
(Assignee)

Comment 3

9 years ago
Created attachment 323981 [details] [diff] [review]
patch
Assignee: nobody → brian.lu
Status: NEW → ASSIGNED
Attachment #323981 - Flags: review?(neil)

Comment 4

9 years ago
Comment on attachment 323981 [details] [diff] [review]
patch

Bug 379070 strikes again!
Attachment #323981 - Flags: review?(neil) → review+
(Assignee)

Updated

9 years ago
Attachment #323981 - Flags: superreview?(mscott)

Updated

9 years ago
Blocks: 379070
Flags: blocking-thunderbird3? → blocking-thunderbird3+

Updated

9 years ago
Attachment #323981 - Flags: superreview?(mscott) → superreview+

Comment 5

9 years ago
thx, Boying
Keywords: checkin-needed
Checking in mailnews/local/src/nsPop3IncomingServer.cpp;
/cvsroot/mozilla/mailnews/local/src/nsPop3IncomingServer.cpp,v  <--  nsPop3IncomingServer.cpp
new revision: 1.99; previous revision: 1.98
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3
You need to log in before you can comment on or make changes to this bug.