Frequent getStart errors using dashboard

RESOLVED FIXED in 3.2

Status

addons.mozilla.org Graveyard
Statistics
--
critical
RESOLVED FIXED
10 years ago
2 years ago

People

(Reporter: mossop, Assigned: fligtar)

Tracking

Details

(Reporter)

Description

10 years ago
Frequently when I change views in the dashboard (this example was switching from the default to the add-on verison view) I get an alert error:

Caught exception: undefined

Details: TypeError: event.getStart() is null

From the console:

Error: XML or text declaration not at start of entity
Source File: https://preview.addons.mozilla.org/en-US/firefox/statistics/xml/events/addon/6543
Line: 120, Column: 1
Source Code:
<?xml version="1.0" encoding="UTF-8"?><data></data>

Error: event.getStart() is null
Source File: https://preview.addons.mozilla.org/js/simile/amo-bundle.js
Line: 8290
(Assignee)

Updated

10 years ago
Assignee: nobody → fligtar
Severity: normal → critical
OS: Mac OS X → All
Hardware: PC → All
Target Milestone: --- → 3.2
Version: unspecified → 3.2
(Assignee)

Comment 1

10 years ago
This was actually being caused by the crazy log-out bug currently on preview, but I also made it so that this is fixed regardless of that since you shouldn't need to be logged in to see any of the event timeline data.

Should be on preview shortly.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.