Closed Bug 424097 Opened 12 years ago Closed 12 years ago

Crash when running runtests.py --a11y, and having JAWS running at the same time.

Categories

(Core :: Disability Access APIs, defect, critical)

x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla1.9

People

(Reporter: MarcoZ, Assigned: MarcoZ)

References

Details

(Keywords: access, crash)

Attachments

(3 files)

Actually, there are two crashes. The first happens if, and only if, I have JAWS running and start the runtests.py with the --a11y parameter. If I quit JAWS before starting the script, and reload it after Firefox has finished loading, and the a11y test harness screen appears, everything is fine.

The second crash happens while running through the Chrome tests. I have a patch coming up for this second one, but I can't get to a stack for the first because I am not able to attach the debugger in time.
Attached patch Add NULL checkSplinter Review
This fixes the crash when running the chrome tests, but not the one at startup. There are other possible null check problems in that method, but they are not the cause of that startup crash.
Attachment #310742 - Flags: review?(surkov.alexander)
Attachment #310742 - Flags: review?(surkov.alexander) → review+
Comment on attachment 310742 [details] [diff] [review]
Add NULL check

This patch is still useful to have even though it doesn't fix the complete problem yet.
Attachment #310742 - Flags: approval1.9b5?
Attachment #310742 - Flags: approval1.9?
MarcoZ asked me to attach my run logs. I find that mochitest crashes on mac os X (10.4) when I run the runtests.pl --a11y and not when I run runtests.py --a11y.  This attachment is from the perl run, and you can see that it appears to crash in cycle collector, though I could not successfully attach a debugger to it to get a true stack trace.
The output from the run that did not crash. Same build, just used runtests.py --a11y instead.
Oh and I should mention that I do not have JAWS running on my Mac, so that may not be a cause of the crash.
Peterv, do you have any idea on this one? These crashes started to happen fairly recently whenever I try to run the a11y Mochitests on Windows, and Clint has reproduced them on Mac as well.
Comment on attachment 310742 [details] [diff] [review]
Add NULL check

a=beltzner
Attachment #310742 - Flags: approval1.9b5?
Attachment #310742 - Flags: approval1.9b5+
Attachment #310742 - Flags: approval1.9?
Attachment #310742 - Flags: approval1.9+
Note to the kind soul doing the checkin: Please leave the bug open since this is only one fix, pending a second one having to do with the same scenario. Thank you!
Keywords: checkin-needed
Comment on attachment 310742 [details] [diff] [review]
Add NULL check

Checking in accessible/src/base/nsAccessible.cpp;
/cvsroot/mozilla/accessible/src/base/nsAccessible.cpp,v  <--  nsAccessible.cpp
new revision: 1.365; previous revision: 1.364
done
The other part of this bug will be fixed once fix for bug 424073 has been checked in.
Depends on: 424073
With the fix for bug 424073 having been checked in, this one is resolved as well.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.