Reword "Get me out of here!" and "Why was this site blocked?"

RESOLVED WONTFIX

Status

()

Toolkit
Safe Browsing
--
trivial
RESOLVED WONTFIX
10 years ago
3 years ago

People

(Reporter: Andrés Delfino, Unassigned)

Tracking

Trunk
Points:
---
Bug Flags:
blocking-firefox3 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5pre) Gecko/2008032006 Minefield/3.0b5pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5pre) Gecko/2008032006 Minefield/3.0b5pre

"Get me out of here!" sounds pretty unprofessional, and I don't think a label ending with a question mark is OK either ("Why was this site blocked?").

Maybe:

Get me out of here!
< Back (note that < is a native arrow in Linux, and no arrow in Windows. Don't know about MacOS)

Why was this site blocked?
Tell me why this site was blocked (I'd actually show this one as a link, and not a button).

Reproducible: Always
(Reporter)

Updated

10 years ago
Version: unspecified → Trunk
I don't think "professionalism" in the sense that you're using it here is a priority, or even necessarily appropriate to the Firefox brand, but in any event, we are past l10n string freeze for Firefox 3.

Leaving open so that we can revisit it post-ship. 
(In reply to comment #1)
> but in any event, we are past l10n string freeze for Firefox 3.

We're past freeze, but we are still taking late-l10n changes (even after b5)...
Not for this, we're not.
Flags: blocking-firefox3-
(Reporter)

Updated

10 years ago
Severity: normal → trivial

Comment 4

9 years ago
professionalism aside, informal language is simply dangerous for international users.  My understanding would be that the en-US locale should avoid colloquialisms and idioms where possible, particularly those whose meanings would be inaccessible even with a dictionary.

Since there appears to be confusion about this, should the locale files maybe actually explain that the locale uses American English conservatively, or even internationally-acceptable English with American spelling?
Is this bug still something that needs to be revisited or put as WontFix at this point. It looks like conversation has ceased and the reporter has not revisited the discussion as well.
(Reporter)

Comment 6

9 years ago
I think this bug still needs to be revisited.
It is entirely intentional that Firefox's "voice" is light and whimsical.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

3 years ago
Component: Phishing Protection → Phishing Protection
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.