Confusing messages about availability of PicLens for Windows

VERIFIED FIXED in 3.2

Status

addons.mozilla.org Graveyard
Public Pages
VERIFIED FIXED
10 years ago
2 years ago

People

(Reporter: AndrewM, Unassigned)

Tracking

All
Windows Vista

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b5pre) Gecko/2008031806 Minefield new Firefox/3.0b4pre
Build Identifier: 

On the PicLens page on the AMO preview site, a message says 'PicLens is not available for Windows' but then right beneath it is a button that says 'Add to Firefox (Windows)'.

Also, on the PicLens Version History page (https://preview.addons.mozilla.org/en-US/firefox/addons/versions/5579) under Version 1.6.1.1029 it says 'PicLens is not available for Windows.PicLens is not available for Windows.PicLens is not available for Windows.PicLens is not available for Windows.PicLens is not available for Windows.' and then beneath it is a button saying 'Add to Firefox (Windows)'.

Reproducible: Always
(Reporter)

Updated

10 years ago
Version: unspecified → 3.2

Comment 1

10 years ago
I am able to confirm this (when faking a Window user agent ;) ).

Technical notes:

The code replacing the install button by the "not available" text cannot handle the fact that Piclens provides several packages for different platforms (thus replacing the Mac OSX install button by the text, and keeping the Windows install button right next to it).

Also, the individual install buttons all have the same id attribute, which is not allowed. They should either have distinct ids, or be wrapped together in a div that has that id. In addition, the id name "install-1234" where 1234 is the addon id has to change because on the versions page there are numerous install buttons for the same add-on. Instead of the addon id, the version id should do fine.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → 3.2

Comment 2

10 years ago
I fixed the ids and the javascript magic so that this issue is fixed now. It's in r11435, and it'll supposedly show up on preview shortly.

Thanks for filing this bug, Andrew.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

10 years ago
VERIFIED FIXED (I won't change the status because I read somewhere that you're not supposed to verify your own bugs :)

(In reply to comment #2)
> Thanks for filing this bug, Andrew.

No problem, thanks for fixing this so quickly :-)  And the new AMO site looks great, btw.

Comment 4

10 years ago
(In reply to comment #3)
> VERIFIED FIXED (I won't change the status because I read somewhere that you're
> not supposed to verify your own bugs :)

You may have misunderstood this: You are not supposed to verify the bugs you *fixed* yourself, not the ones you *filed* yourself. The former is to prevent you from seeing only what you want to see instead of what's actually there :)
(Reporter)

Comment 5

10 years ago
(In reply to comment #4)
> (In reply to comment #3)
> > VERIFIED FIXED (I won't change the status because I read somewhere that you're
> > not supposed to verify your own bugs :)
> 
> You may have misunderstood this: You are not supposed to verify the bugs you
> *fixed* yourself, not the ones you *filed* yourself. The former is to prevent
> you from seeing only what you want to see instead of what's actually there :)

Ah, that makes sense, thanks for clarifying that :)
Status: RESOLVED → VERIFIED
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.