If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

when dragging object into menu, but leaving the menu, menu should close itself

NEW
Unassigned

Status

()

Firefox
Menus
10 years ago
3 years ago

People

(Reporter: Jakub 'Livio' Rusinek, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pl; rv:1.9b5pre) Gecko/2008032004 Fedora/8 (Werewolf) Minefield/3.0b5pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; pl; rv:1.9b5pre) Gecko/2008032004 Fedora/8 (Werewolf) Minefield/3.0b5pre

when dragging tab or link into "bookmarks" menu, menu opens (that's nice), but when leaving it, it doesn't close.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Actual Results:  
when dragging object into menu, it opens, but doesn't close, when leaving (still dragging)

Expected Results:  
menu should behave like bookmark folders on toolbar
Component: Bookmarks → Menus
QA Contact: bookmarks → menus
Version: unspecified → Trunk
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 422778
Reopening. This bug is not a dupe of bug 422778 because dragging onto and dragging into are two different bugs, and bug 422778 has a different cause.
Maybe both bugs can be fixed by one patch, but it is not entirely the same bug.
I can reproduce this on Windows as well.

A third similar but not quite same bug is Bug 430551.
Status: RESOLVED → UNCONFIRMED
Depends on: 422778, 430551
OS: Linux → All
Hardware: PC → All
Resolution: DUPLICATE → ---
Status: UNCONFIRMED → NEW
Ever confirmed: true
Note that dragging into the menu itself that opens and then continuing to drag out of the menu causes the menu to close.

But merely dragging across the "Bookmarks" item in the menubar (without entering the menu itself) leaves the menu open.

It stays open even after minimizing the parent window, and then it becomes difficult to make the menu get out of your way.
WFM in actual Firefox 34 on Win7

looks like it was solved over the last 5 years.
can someone confirm this?
You need to log in before you can comment on or make changes to this bug.