Midas: ctrl+del deletes text marked as contentReadOnly

RESOLVED WONTFIX

Status

()

Firefox
General
--
minor
RESOLVED WONTFIX
10 years ago
8 years ago

People

(Reporter: N00107955, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-07-30])

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; FDM; .NET CLR 2.0.50727)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12

Pressing ctrl+del or shift+del on selected text in an iframe with designMode enabled will delete the text, regardless of whether the document was set to contentReadOnly or not.

Reproducible: Always

Steps to Reproduce:
1. Create an iframe with source data (src="blah.html") and enable designMode
2. call execCommand() on this iframe with the 'contentReadOnly' command
3. As expected, typing in the iframe will not edit the text
4. select text and press ctrl+del or shift+del
Actual Results:  
The selected text is deleted

Expected Results:  
The selected text should not be deleted

I will try to attach an example html file to demonstrate this problem, as I realize the steps to reproduce it may be somewhat vague.
(Reporter)

Comment 1

10 years ago
Created attachment 310773 [details]
simple test case

Funny thing happened when trying to reproduce this bug: Another bug (bug #304994) makes it appear as though the iframe was read-only whenever you navigate away from the page and then back because designMode gets disabled.
Reporter, are you still seeing this issue with Firefox 3.6.x or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Whiteboard: [CLOSEME 2010-07-30]
Version: unspecified → 2.0 Branch
(Reporter)

Comment 3

8 years ago
I haven't tested it in 3.6.x safemode, but seeing how the bug still existed in 3.5.3 it is clear to me that this bug is of little importance.
(Reporter)

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.