me.dium.com display not working in FF3

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
11 years ago
3 years ago

People

(Reporter: mkaply, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

11 years ago
me.dium.com has a display where images pop in to show page relationships.

This doesn't work on FF3. It worked on FF2 and works on IE.

I checked as far back as beta 2.

There are no errors in the console.
(Reporter)

Updated

11 years ago
Keywords: regression
(Reporter)

Comment 1

11 years ago
Sorry, more detail.

Load the URL.

On FF2 or IE, the black area will have icons in it. On FF3, it doesn't.
So... I can reproduce this in trunk Firefox or in any Seamonkey version I have here.

Setting the general.useragent.override preference to

  Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.8.1.11) Gecko/20071127
  Firefox/2.0.0.11

fixes it in all those browsers.

Want to contact the site and get them to fix their UA sniffing?
Assignee: nobody → english-us
Component: Layout → English US
Keywords: regression
Product: Core → Tech Evangelism
QA Contact: layout → english-us
Version: Trunk → unspecified

Comment 3

11 years ago
We've found and fixed the problem, I'll post again once the fix is live (should be tonight).

Thanks for the report!

-peter

Comment 4

11 years ago
The fix is live.  Thanks again!

-peter
Peter, it still doesn't seem to work right for me either in a trunk nightly (which identifies itself as Minefield, not Firefox), or in SeaMonkey...  Might I ask what string you're sniffing for?

Comment 6

11 years ago
It looks specifically for "Firefox", and also for specific versions thereof.  Our activity shares code with our widget, which tries to fall back to being a simple badge if it's in a browser in which we're not sure it'll work properly.  That's a decision we should probably revisit, at least in the context of activities... unfortunately with activities, the fallback code is disabled too!

Come to think of it, we should probably just look for Gecko in the UA string, and check its version.  We'll look into this further--but for now, you'll have to twiddle your UA string if your browser isn't branded as Firefox 1.5-3, IE 6-8, or Safari.

-peter
(Reporter)

Comment 7

11 years ago
What Firefox feature are you using?

Please check out this site:

http://geckoisgecko.org/

We'd love to help you guys get a better solution to this.

Comment 8

11 years ago
It's not so much features as it is layout, AFAIK.  Sounds like we should be using geckoGetRv() instead of the hack we're using now.  Thanks for the pointer, I'll pass it on to the engineers who have recently taken this code over.  It'll take at least a few days to get this into production (holidays, testing, etc.), but I'll post back here once we've done it.

Thanks again!

-peter
> Come to think of it, we should probably just look for Gecko in the UA string,

Yeah, that would best.  Thank you for looking into this more!

Comment 10

11 years ago
The change to use geckoGetRv() is now live.  The activity and for that matter all our widgets should now work in any Gecko >= 1.8 application.

Thanks for your help!

-peter
Confirmed that branch seamonkey now works too.  Peter, thanks!
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.