Mouse click selects link. Must click again to activate. Dell tablet PC with Vista.




10 years ago
9 years ago


(Reporter: Emily Corse, Unassigned)


Firefox Tracking Flags

(Not tracked)




10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv: Gecko/20080201 Firefox/
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv: Gecko/20080201 Firefox/

This is an issue with at least some tablet PCs. Also true trying to click hyperlink in Thunderbird message. I've heard it's a problem in OneNote as well. See forums: 

Rumor suggests it might be a trackpad driver, but it's very frustrating to find info. I must double-click all links in Firefox or switch to IE!

Reproducible: Always

Steps to Reproduce:
1.use Dell Latitude XT with Vista
2.launch Firefox
3.try clicking on a link
Actual Results:  
The link is selected, but nothing happens. Think you maybe missed the link? Click again and link is activated.

Expected Results:  
After this happens a few times, you realize you are not clicking impaired. Double-click works every time to follow regular ol' hyperlinks.

Comment 1

10 years ago
Yes, having the same problem here. Dell Latitude XT running Vista business. Both Thunderbird and Firefox have to be clicked twice before the new page gets loaded. I upgraded to Firefox 3 and same thing happens.

Additional observations: mostly works mostly don't work (needs 2 clicks)

Comment 2

10 years ago
i do not have a dell product, i also do not use a touchpad, but i am experiencing the same problems.  sometimes, i have to click a third time to get the link to work.  it is not due to add-ins because my computer at home has add-ins for firefox but my computer at work does not and this occurs at both computers which use microsoft mice -- no touchpads.

Comment 3

9 years ago
I am having the exact same issue. Dell Latitude XT tablet running vista. Reinstall of Firefox has no effect. Safe mode has no effect.

Comment 4

9 years ago

It's a simple registry edit - changing or refreshing 2 values.

Here is the Fix, and it works.

Thanks to Daniel Escapa

OneNote Dell XT Tablet fix:

"I heard reports that if you had the new Dell XT Tablet some things in OneNote were not clickable and you were probably having a hard time using OneNote. Whenever you tried to click on something it would end up being a drag action. Well some Devs on the team took a new Dell XT Tablet and debugged it and found out what was going on. The problem is with the NTrig applet which is installed by Dell and during the first couple logons, it sets a bunch of default registry values which causes problems. They have posted a way to fix this, but it modifies the system registry so please take caution before messing with the registry.

Click Start, Run, type regedit, and click ok (acknowledge the Vista UAC prompt if it comes up).
In the registry editor, navigate to "Computer\HKEY_CURRENT_USER\Control Panel\Desktop"
Locate the DragHeight and DragWidth values in the right hand pane
Select the DragHeight value, click the Edit menu, and select Modify (you can double click as well to modify)
In the Value Data field, type 4 and click ok. IMPORTANT! You need to do this step even if the registry editor already shows the value as 4!
Repeat steps 4 and 5 with the DragWidth field.
Logoff or reboot your computer.

If these steps don’t work for you please let us know in the comments and we will get in touch with you (or just email). Also note that with time a new user is created on the system this tool will run again and you will have to repeat these steps for that profile. We I understand we (Microsoft, not OneNote) is in touch with Dell regarding this issue.

Thanks a bunch Jason & Ilya…and I hope this works for everyone else out there! Enjoy the nice new Tablets

Published Friday, April 11, 2008 1:45 AM by descapa "
rjo is offline   	Reply With Quote

Comment 5

9 years ago
This is confirm that the above solution works for me. My registry's DragHeight and DragWidth values were already 4, but I retyped 4 as instructed and now both Firefox and Thunderbird works fine. Thanks very much for working out the solution Bryan, Daniel, Jason and Ilya. Kudos to OneNote devs team!

Comment 6

9 years ago
Bryan Thompson's regedit fix worked for me too, when I first tried it more than a year ago. Just wanted to mention that yesterday, I started having to double-click links in Firefox again... no idea what changed. Fortunately, Bryan's fix worked again. Thanks. --Emily C.
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.