Multiple crashes on sites, xul.dll errors and more!

RESOLVED DUPLICATE of bug 424165

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 424165
10 years ago
10 years ago

People

(Reporter: Recall, Unassigned)

Tracking

({dogfood})

Trunk
x86
Windows Vista
dogfood
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; WOW64; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; Media Center PC 5.0)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b5pre) Gecko/2008032012 Minefield/3.0b5pre

After latest nightly update I am getting multiple crashes on loads of sites. I cannot even access bugzilla without firefox crashing on the latest hourly.
 I have included a site as test url, but there are many others.

This is a major issue, it is crashing all over the place. I have noticed firefox being more crashy in the last few builds, but tonight it is worse than ever.

here are some crash reports

http://crash-stats.mozilla.com/report/index/31ddf7a1-f6cc-11dc-bde3-001a4bd43e5c
http://crash-stats.mozilla.com/report/index/f78674f0-f6cc-11dc-8462-001a4bd43ed6
http://crash-stats.mozilla.com/report/index/05424ade-f6cc-11dc-ac83-001a4bd43e5c
http://crash-stats.mozilla.com/report/index/e82a04c0-f6cb-11dc-9551-001a4bd43ed6

Also I tried to load Landscape pro website and it crashed with xul.dll error in Vista. Breakpad completely failed in this case.

http://www.landscape-pro.net/

Problem Event Name: APPCRASH
Application Name: firefox.exe
Application Version: 1.9.0.3001
Application Timestamp: 47e2d4bf
Fault Module Name: xul.dll
Fault Module Version: 1.9.0.3001
Fault Module Timestamp: 47e2d51f
Exception Code: c0000005
Exception Offset: 0014e8d3
OS Version: 6.0.6001.2.1.0.256.1
Locale ID: 2057
Additional Information 1: fd00
Additional Information 2: ea6f5fe8924aaa756324d57f87834160
Additional Information 3: fd00
Additional Information 4: ea6f5fe8924aaa756324d57f87834160





Reproducible: Always

Steps to Reproduce:
1.Load site in url link
2.
3.
Actual Results:  
Crashing on multiple sites.

Expected Results:  
Should not crash.
(Reporter)

Updated

10 years ago
Flags: blocking-firefox3?
Keywords: dogfood
Summary: http://derstandard.at/ → Multiple crashes on sites, xul.dll errors and more!
(Reporter)

Comment 1

10 years ago
Ok, it is a faulty xul.dll that is causing the problem. I just pasted one from a few days ago in to my mozilla folder and it works fine. Not sure on the regression range yet.
This is probably a dupe of bug 424165 or bug 424163. Please test with an hourly build after its been built and resolve this bug if appropriate. Thanks!
(Reporter)

Comment 3

10 years ago
Ok, thanks. I will resolve if fixed!
(Reporter)

Comment 4

10 years ago
Just tested with latest nightly and not crashing anymore. So it appears those fixes resolved this one. Therefore I will dupe against one of those.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b5pre) Gecko/2008032015 Minefield/3.0b5pre
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 424165

Updated

10 years ago
Flags: blocking-firefox3?
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.