Firefox hangs after indeterminate period of time since latest OS X updates

VERIFIED INCOMPLETE

Status

()

Firefox
General
--
critical
VERIFIED INCOMPLETE
10 years ago
8 years ago

People

(Reporter: george palfi, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2009-01-12)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12

Since I updated my Mac with the latest updates from Tuesday, and Wednesday this week (Mar. 19, 20), Firefox becomes unresponsive after a period of time.  This does not seem to be linked to any particular URL, or to any particular action.  Since I noticed it today, it may be related to the last update Time Machine and AirPort Updates.  I did notice on one of my Macs (MacBook Pro) that installing this update changed the setting for Configure Settings to Access the Internet.  I had to put it back to Auto-Detect.  But, this did not happen on two other Macs.  The hanging has occurred on two of the Macs, and I have to use Force Quit to quit Firefox.  Sometimes it does not happen for an hour, and other times it happens every few minutes.  Clearly, something in the updates is conflicting with something in Firefox.

Reproducible: Always

Steps to Reproduce:
1.Let Firefox sit with multiple Tabs open.  Perhaps sites with auto-refresh may provoke.
2.
3.
Actual Results:  
Firefox hangs.  Need to use Force Quit to stop.  

Expected Results:  
Should not hang.
(Reporter)

Comment 1

10 years ago
Created attachment 311045 [details]
Apple generated bug report when I use Force Quit to close Firefox

Perhaps the Apple bug report can help
(Reporter)

Comment 2

10 years ago
Update to 2.0.0.13 did not help.  This problem only seems to happen on my MacBook and MacBookPro, but not on my MacPro which uses a seperate mouse.  Could it be related to the trackpad function?  I have been using Firefox since 0.6 and have never had such a severe bug.  Am forced to use Safari.  I have sent dozens of error reports to Apple (as attached) every time I use Force Quit on my two notebooks.

Comment 3

10 years ago
This happens with firefox 3b5 as well as 2.0.0.11.
I've tried safe mode, disabling extensions and using a new profile.
Nothing seems to fix it.

Like others have observed, the apple update around March 19th should be considered a major suspect.

Comment 4

10 years ago
do you still see this problem using Firefox 3?
If you do, please comment.
If you do not, please close with resolution set to WORKSFORME.
Whiteboard: closeme 2009-01-12

Updated

9 years ago
Blocks: 483013

Comment 5

9 years ago
=> incomplete due to no response
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE

Updated

8 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.