[Win9x only]build still tries to do libs phase

VERIFIED FIXED in M17

Status

SeaMonkey
Build Config
P3
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: dbaron, Assigned: dbaron)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

18 years ago
I'm building on Win98 (with OS_TARGET=WIN95), and I did nmake /f client.mak 
build_all, and it recursed through the entire tree structure on the libs phase, 
giving messages that the libs phase is deprecated (I forget the exact message).

This seems to have something to do with the special Win95 rules around:
http://lxr.mozilla.org/seamonkey/source/config/rules.mak#328

It looks like something wasn't fixed when the libs phase was eliminated.

Comment 1

18 years ago
Reassigning to warren as he originally removed the libs phase from the windows
build.  (Bounce it back if I'm misremembering.)
Assignee: cls → warren

Comment 2

18 years ago
I don't have a win98 environment, so I'm going to bounce this back.
Assignee: warren → cls
(Assignee)

Comment 3

18 years ago
I think the problem is the middle of the 3 changes in r3.41 of rules.mk.  I 
think that should be undone.  I'll test it the next time I feel like building 
(hopefully after I get more RAM).

Assigning to myself, since I doubt anybody else cares, and cc:ing hyatt, since I 
think he builds on Win9x.
Assignee: cls → dbaron
(Assignee)

Comment 4

18 years ago
Created attachment 10659 [details] [diff] [review]
proposed patch

Comment 5

18 years ago
David Baron wrote:

  Could you review the patch I attached to bug 42428 (Win95 build still
  goes through libs phase)?  I did a successful clobber build with it this
  weekend (and it took 5 hours instead of 12).

It looks like you just moved the w95libs target from install to libs. First, I 
don't understand why that fixes it since we're trying to eliminate the libs 
phase and do everything during the install phase. Second, I don't understand how 
this change would make the build time go down -- if anything it would go up 
since you're recursing over the tree one extra time. 

I think what you want to do here is figure out what isn't happening for w95 
during the install phase, and fix that.

(Assignee)

Comment 6

18 years ago
The w95* targets are just a hack (as I understand it) to get around the 
limitations of the W95 command.com.  w95libs just recursively calls the
libs target.  So this is causing the libs phase to be run within the install 
phase, once for *every* level of the recursion into subdirectories.  So I
think this is the right fix, unless you want to remove w95libs from the makefile 
completely (which I'd rather not mess with). 
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M17
(Assignee)

Comment 7

18 years ago
Fix checked in (r=warren).
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 8

18 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.