Failure-alert dialog is not appeared on attempt to download non-existent file

UNCONFIRMED
Unassigned

Status

()

UNCONFIRMED
11 years ago
10 years ago

People

(Reporter: viktoriia.bogdanova, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008032102 Firefox/3.0b5pre Flock/1.3pre
Build Identifier: Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008032102 Firefox/3.0b5pre Flock/1.3pre

Failure-alert dialog is not appeared on attempt to download non-existent file.

Reproducible: Always

Steps to Reproduce:
1. Launch FF.
2. Navigate to http://www.domain.fake/non_existent_document.pdf link 
   - > “The requested URL could not be retrieved” web page is displayed
3. Right click on http://www.domain.fake/non_existent_document.pdf link and choose “Save Link As”     
   - > “Save As” window is opened with “non_existent_document.pdf” in File name field
4. Choose the directory to save and click “Save” button

Actual Results:  
“Downloads” window is opened and displays the downloaded file “non_existent_document.pdf”. Failure-alert dialog is not appeared. The downloaded file can not be opened.

Expected Results:  
Failure-alert dialog is appeared. The file can not be downloaded at all.
(Reporter)

Comment 1

11 years ago
The specified build is incorrect. 
The correct build is - Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008032005 Minefield/3.0b5pre
Since you get a webpage, when you save link as it's going to save whatever content the web page serves you.  If you open that file that you saved, it should be the 404 page.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
I need to take a look at this; either: A) the testcase is wrong B) there's a regression.  I remember this actually working (I'll test tomorrow; bedtime now).

Shawn, the "webpage" is actually just the Firefox error page, so there shouldn't be anything returned.  I might have written the testcase wrong, and this never worked (i.e. perhaps the testcase should only test a non-existent file on a REAL host and see what a "fail" looks like).

Regardless, reopening for (my) investigation and tracking, at least.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.