Action "Clear Private Data" (Ctrl+Shift+Del) doesn't clear browsing history

VERIFIED INVALID

Status

()

VERIFIED INVALID
11 years ago
10 years ago

People

(Reporter: vladimirkondratyev, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008032005 Minefield/3.0b5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008032005 Minefield/3.0b5pre

Location bar continue to complete visited pages after Ctrl+Shift+Del is performed. 

At the same time browser history which is shown by Ctrl+H is empty.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
-> invalid

Awesomebar contains more as the history (bookmarks) and please search before you file a bug, this information is very easy to find.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID

Comment 2

11 years ago
True. The location bar also shows bookmarks, not just your history. So clearing the history will not result in an empty location bar,
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

11 years ago
The problem is that 3 days ago (in one of previous builds) Ctrl+Shift+Del cleared location history perfectly. And of course Ctrl+Shift+Del works in FF2.

Current behavior is not secure. How can I delete visited pages from location bar? Term "Browsing history" is overloaded and of course it means items which are stored somewhere in location bar.

Please reconsider the status of this bug report.

Comment 4

11 years ago
If the sidebar is empty, then the history has been erased. The one you see are *bookmarks*, and can also be found in the 'Organize Bookmarks'. Really. But they're sorted by visit-frequency, that's why you see the most visited sites at the top.

ctrl-shift-del does NOT clear the location bar.

Updated

11 years ago
Duplicate of this bug: 427032

Comment 6

11 years ago
if this is not a bug then how do you clear the location bar 
yes they show as bookmarks (star) but do not go away when you delete the bookmarks either.   and that is how it worked in ff2 Ctrl+shift+del  to delete browsing history

Comment 7

11 years ago
Of course they're not being deleted because you're not actually deleting the bookmarks.

If you want no results to show up go to: about:config

And set browser.urlbar.maxRichResults to 0.

If you want the AwesomeBar to search through only History, check out bug 424557

Comment 8

11 years ago
In previous versions of Firefox, you were able to go:

tools-->clear private data-->browsing history then click on the button, clear private data now.
This would remove all infomation in the browser.urlbar context menu (drop down arrow to the right of the url bar).
This does not happen in firefox 3.0b5.

setting browser.urlbar.maxRichResults to 0 seems to be a workaround.

Comment 9

11 years ago
(In reply to comment #8)
> In previous versions of Firefox, you were able to go:
> 
> tools-->clear private data-->browsing history then click on the button, clear
> private data now.
> This would remove all infomation in the browser.urlbar context menu (drop down
> arrow to the right of the url bar).
> This does not happen in firefox 3.0b5.
> 
> setting browser.urlbar.maxRichResults to 0 seems to be a workaround.
> 

The AwesomeBar also searches bookmarks, clearing private data does not delete bookmarks. So it's not expected behaviour that all information in the AwesomeBar is removed.

Comment 10

10 years ago
probably a dupe of bug 423507
You need to log in before you can comment on or make changes to this bug.