If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

crash when printing page after print preview [@ nsPrintEngine::SetupToPrintContent]

RESOLVED DUPLICATE of bug 423345

Status

()

Core
Printing: Output
--
critical
RESOLVED DUPLICATE of bug 423345
10 years ago
6 years ago

People

(Reporter: Wouter van Wijk, Unassigned)

Tracking

({crash})

Trunk
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4

Crash when printing this page:
http://www.informationweek.com/shared/printableArticle.jhtml?articleID=206504325
after print preview

Reproducible: Always

Steps to Reproduce:
1. go to http://www.informationweek.com/shared/printableArticle.jhtml?articleID=206504325
2. select File _> Print Preview
3. Press Print Button
Actual Results:  
crash

Expected Results:  
a print
(Reporter)

Comment 1

10 years ago
I also tried this in safe mode, with the same results.
Please type about:crashes and provide the crash id from such a submitted crash report.
(Reporter)

Comment 3

10 years ago
I found these three:
922b9dba-f749-11dc-b01e-001a4bd43ef6
3f80e21e-f749-11dc-afe3-001a4bd46e84
1a7fd511-f749-11dc-b5e8-001a4bd43ed6

Comment 4

10 years ago
Signature	nsPrintEngine::SetupToPrintContent()
UUID	1a7fd511-f749-11dc-b5e8-001a4bd43ed6
Time	2008-03-21 06:16:33-07:00
Uptime	15
Product	Firefox
Version	3.0b4
Build ID	2008030714
OS	Windows NT
OS Version	5.1.2600 Service Pack 2
CPU	x86
CPU Info	GenuineIntel family 6 model 13 stepping 8
Crash Reason	EXCEPTION_ACCESS_VIOLATION
Crash Address	0x0
Comments	
Crashing Thread
Frame 	Signature 	Source
0 	nsPrintEngine::SetupToPrintContent() 	mozilla/layout/printing/nsPrintEngine.cpp:1720
1 	nsPrintEngine::DocumentReadyForPrinting() 	mozilla/layout/printing/nsPrintEngine.cpp:1425
2 	nsPrintEngine::Observe(nsISupports*, char const*, unsigned short const*) 	mozilla/layout/printing/nsPrintEngine.cpp:3126
3 	nsPrintProgress::DoneIniting() 	mozilla/embedding/components/printingui/src/win/nsPrintProgress.cpp:221
4 	NS_InvokeByIndex_P 	mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp:101
5 	XPCWrappedNative::CallMethod(XPCCallContext&, XPCWrappedNative::CallMode) 	mozilla/js/src/xpconnect/src/xpcwrappednative.cpp:2369
Component: General → Printing
Keywords: crash
Product: Firefox → Core
QA Contact: general → printing
Summary: crash when printing page after print preview → crash when printing page after print preview [@ nsPrintEngine::SetupToPrintContent]
Version: unspecified → Trunk
Confirmed with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008030305 Minefield/3.0b4pre

WFM with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008032505 Minefield/3.0b5pre

bug 423345 has same signature [nsPrintEngine::SetupToPrintContent()] and was fixed on 20080319

Marking duplicate.

Wouter, this will be fixed in beta 5. If you can test when it is available and it isn't fixed, please reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 423345
(Assignee)

Updated

6 years ago
Crash Signature: [@ nsPrintEngine::SetupToPrintContent]
You need to log in before you can comment on or make changes to this bug.