One message eats 50% CPU when Inbox is displayed

RESOLVED DUPLICATE of bug 415135

Status

Thunderbird
Mail Window Front End
--
major
RESOLVED DUPLICATE of bug 415135
11 years ago
11 years ago

People

(Reporter: Xavier Verne, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.1.12) Gecko/20080207 Ubuntu/7.10 (gutsy) Firefox/2.0.0.12
Build Identifier: version 2.0.0.12 (20080227)

1. Receive this spam whose title is "Jessica Alba leaked porn tape"

If you want to display the message list of the folder containing this message, the whole interface just kinda freeze, CPU is 55% for like 1mn or two. 

I was suspecting this to happen because of a unique message, and I could identify the message which is freezing UI.

Removing this message from my Inbox and then from my Trash folder successfully gave me back responsiveness of UI.

I attach my "Trash folder" (text file) to this bug in order for you identify precisely which string in the message (looks Unicode and strange) causes the freeze.

Reproducible: Always

Steps to Reproduce:
1. Get this message
2. Try to display the folder containing this message
3. Wait for the interface....


Expected Results:  
Not hanging, just displaying list of messages.

See attachment.
(Reporter)

Comment 1

11 years ago
Created attachment 310974 [details]
Zipped Trash folder (thunderbird mail format coming from mail directory)

Pb message is the f*** SPAM titled "Jessica Alba leaked porn tape".

Happy SPAMMING !
Just an insanely long From header (~131000 characters, most of them repeating "ºŽZîúNš®:.ÚnzÎ.."), which was recently fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 415135
You need to log in before you can comment on or make changes to this bug.