Color profiles handled differently in Firefox 3-beta4 and Safari 3.1

VERIFIED WORKSFORME

Status

()

Core
General
--
minor
VERIFIED WORKSFORME
10 years ago
9 years ago

People

(Reporter: Ernst de Haan, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; nl; rv:1.9b4) Gecko/2008030317 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; nl; rv:1.9b4) Gecko/2008030317 Firefox/3.0b4

Color profiles are apparently handled differently in Safari 3.1 and Firefox 3 beta 4 (with color profile support enabled). I'll post a screenshot with the two next to eachother.

I'm not sure this is a bug in either one. This is just to support the development of the (experimental?) color profile support in Firefox 3.

Reproducible: Always

Steps to Reproduce:
1. Have a specific color profile configured for your screen (? not sure this is necessary)
1. Start Firefox 3.0-beta 4 on Mac OS X 10.4.11.
2. Start Safari 3.1.
3. Open a site (in both browsers) that uses PNG images without a color profile and has a background color specified in CSS that is supposed to match the color in one or more of the PNG files, such as http://www.route65.eu/
Actual Results:  
The results differ, the background color specific in CSS is rendered differently.

Expected Results:  
Same results in both browsers.
(Reporter)

Comment 1

10 years ago
Created attachment 310981 [details]
Screenshot showing Safari 3.1 and Firefox 3.0-beta4 side-by-side.
(Reporter)

Comment 2

10 years ago
Sorry, I must some steps, between step 1 and step 2:

1.1 Go to about:config
1.2 Confirm you want to edit settings
1.3 Set the option "gfx.color_management.enabled" to "true"
1.4 Restart Firefox

Comment 3

10 years ago
WebKit only uses colour correction for images, not for css/html colours, whereas in Gecko, everything is colour-corrected.
Component: General → General
Product: Firefox → Core
QA Contact: general → general
Version: unspecified → Trunk
Right; this is WORKSFORME -- Gecko is working as intended (and in the test site, you'll note that the image blends correctly into the background).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

9 years ago
Sure, fine by me, marking as verified. Indeed, the behaviour of Firefox/Gecko produces a more workable result for web developers, there is no visual glitch.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.