Customize Toolbar ▸ Restore Default Set uses gtk-refresh instead of gtk-revert-to-saved

VERIFIED FIXED in Firefox 3.1b3

Status

()

Firefox
Theme
--
trivial
VERIFIED FIXED
10 years ago
9 years ago

People

(Reporter: Andrés Delfino, Assigned: Dolske)

Tracking

({polish, verified1.9.1})

Trunk
Firefox 3.1b3
All
Linux
polish, verified1.9.1
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [polish-easy] [polish-visual][polish-p2])

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5pre) Gecko/2008032107 Minefield/3.0b5pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5pre) Gecko/2008032107 Minefield/3.0b5pre

Since we are not refreshing anything, but reverting changes gtk-undo should be used.

Reproducible: Always
(Reporter)

Comment 1

10 years ago
Created attachment 310989 [details]
Screenshot.
(Reporter)

Updated

10 years ago
Version: unspecified → Trunk
(Reporter)

Updated

10 years ago
Summary: Customize Toolbar > Restore Default Set uses gtk-refresh instead of gtk-undo → Customize Toolbar ▸ Restore Default Set uses gtk-refresh instead of gtk-undo

Updated

10 years ago
Blocks: 381206
If anything, use gtk-revert-to-saved. The icon gtk-undo is for undoing one step, which is not the case here. So, gtk-revert-to-saved or no icon.
(Reporter)

Comment 3

10 years ago
(In reply to comment #2)
> If anything, use gtk-revert-to-saved. The icon gtk-undo is for undoing one
> step, which is not the case here. So, gtk-revert-to-saved or no icon.
> 

You're absolutely right; actually, I was going to morph this bug.

I think the gtk-revert-to-saved works fine here.
Summary: Customize Toolbar ▸ Restore Default Set uses gtk-refresh instead of gtk-undo → Customize Toolbar ▸ Restore Default Set uses gtk-refresh instead of gtk-revert-to-saved

Updated

10 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Updated

10 years ago
OS: All → Linux
Blocks: 425582
Keywords: polish
Whiteboard: [polish-easy] [polish-visual]
(Assignee)

Comment 4

10 years ago
Created attachment 350557 [details] [diff] [review]
Patch v.1
Assignee: nobody → dolske
Attachment #310989 - Attachment is obsolete: true
Attachment #350557 - Flags: review?(gavin.sharp)
(Assignee)

Comment 5

10 years ago
Created attachment 350558 [details]
Screenshot (patch v.1)
Attachment #350558 - Flags: ui-review?(faaborg)
(Assignee)

Comment 6

10 years ago
(New icon is the top in the screenshot, old icon is the bottom).

The change to customizeToolbarSheet.xul probably isn't needed (seems to be mac only), but I figured I'd just keep them more or less in sync.
Attachment #350557 - Flags: review?(gavin.sharp) → review+
Comment on attachment 350557 [details] [diff] [review]
Patch v.1

>diff --git a/toolkit/content/customizeToolbar.xul b/toolkit/content/customizeToolbar.xul

>+    <button label="&restoreDefaultSet.label;" oncommand="restoreDefaultSet();"
>+icon="revert"/>

What's with the odd indent?
Comment on attachment 350558 [details]
Screenshot (patch v.1)

I'm assuming these are the correct icons. I actually don't know what gtk-revert-to-saved looks like.
Attachment #350558 - Flags: ui-review?(faaborg) → ui-review+
(Assignee)

Updated

10 years ago
Attachment #350557 - Flags: approval1.9.1?
(Assignee)

Comment 9

10 years ago
Pushed http://hg.mozilla.org/mozilla-central/rev/f03bb4a3ce53
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Comment on attachment 350557 [details] [diff] [review]
Patch v.1

a191=beltzner
Attachment #350557 - Flags: approval1.9.1? → approval1.9.1+
(Assignee)

Comment 11

10 years ago
Pushed to 1.9.1: http://hg.mozilla.org/releases/mozilla-1.9.1/rev/a511a6815305
Keywords: fixed1.9.1
Target Milestone: --- → Firefox 3.1b3

Comment 12

10 years ago
Verified fix on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b3pre) Gecko/20090122 Shiretoko/3.1b3pre
and Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090122 Minefield/3.2a1pre
Status: RESOLVED → VERIFIED
Keywords: fixed1.9.1 → verified1.9.1
This bug's priority relative to the set of other polish bugs is:
P2 - Polish issue that is in a secondary interface, occasionally encountered, and is easily identifiable.

customize toolbar interface is a secondary UI, assuming the icon difference was obvious.
Whiteboard: [polish-easy] [polish-visual] → [polish-easy] [polish-visual][polish-p2]
You need to log in before you can comment on or make changes to this bug.