Seamonkey can't be set as default browser in Vista SP1

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: jochem.meyers, Unassigned)

Tracking

Trunk
x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.12) Gecko/20080201 MultiZilla/1.8.3.4e SeaMonkey/1.1.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.12) Gecko/20080201 MultiZilla/1.8.3.4e SeaMonkey/1.1.8

After trying to set IE as default browser to test opening a WebDAV share as a webfolder in Vista (which works badly to begin with), I tried setting Seamonkey back as the default, but to no avail.

I expected seamonkey to give me the "I'm not the default browser" popup upon opening the first time (I have it set to always check), but it didn't. When I went into preferences to set it manually, the "Set default browser" button was greyed out because 'Seamonkey is already [my] default browser'.

I tried going to the default programs option in the control panel. Under 'Set your default Programs', Seamonkey isn't listed, but Firefox (2.0.0.12) and IE7 are.

In the "Set Program Access and Computer Defaults" dialog, I can select Seamonkey, but it doesn't change the protocol or file associations.

In the Associate a file type or protocol with a program, the only two applications I can pick for HTTP and so on are Firefox and IE.

I've also tried going to Preferences, Advanced, System, unchecking all the boxes (they were checked), restarting seamonkey, and rechecking them, but still it wasn't the default browser.

I've googled to try and find a solution. People suggested running 'firefox.exe -silent -setDefaultBrowser' (not sure on the spelling for that last option, I copied it off a mozilla site when I ran the command), which I did with firefox.exe replaced with seamonkey.exe, but that didn't work either.

I've also tried reinstalling Seamonkey. During the first run of the new installation, it asked me whether I wanted to set it as the default browser, I selected 'Yes', but _still_ Seamonkey doesn't behave as the default, though the default option stays greyed out in the preferences panel.

After all this, I tried going into the registry to see if I could set it up there. I set Firefox as the default browser and started searching for 'firefox.exe' in the registry. I ran into the following situation.

There's a registry setting, HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\FIREFOX.EXE\Capabilities for Firefox, that doesn't exist for Seamonkey
Then there's HKEY_LOCAL_MACHINE\SOFTWARE\RegisteredApplications where the list of available 'default applications' exists, which references that first key

After some more searching, I found that the values (FirefoxURL, FirefoxHTML) in the first key (FIREFOX.EXE\Capabilities) are references to values of HKEY_CLASSES_ROOT. There are keys called 'MozillaHTML' and such there, but no MozillaURL or Seamonkey*.

As I understand this problem now, Seamonkey would need that HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\Seamonkey\Capabilities key, which doesn't seem to be created by the default installation.

Perhaps I'll try this weekend to copy and adjust the values from the Firefox Capabilities key, to see if that would let me select seamonkey as default browser.

Reproducible: Didn't try

Steps to Reproduce:
I can't reproduce this because Seamonkey needs to be the default browser first.
1. Have Seamonkey as the default browser (I had this set pre-SP1)
2. Make Internet Exploder the default browser.
3. Try to make Seamonkey the default browser again, through any means.
Actual Results:  
The only actual change I've managed to see is that Seamonkey is listed as the internet link at the top of the start menu.

Expected Results:  
Seamonkey should be default browser for URLs from other applications, html files, urls from the Run dialog...
Can you reproduce with SeaMonkey v1.1.9 ?
Version: unspecified → SeaMonkey 1.1 Branch

Comment 2

11 years ago
I am having the same exact problem.  I'm using an HP Vista SP1 and SeaMonkey v1.1.9.  I have a feeling this has to do with the following Protocols NOT being set to SeaMonkey.

FTP             URL:File Transfer      			Internet Explorer   
GOPHER          Firefox                			Internet Explorer
HTTP            URL:HyperText Transfer Protocol         Internet Explorer
HTTPS           URL:HyperText Transfer Protocol with Privacy Internet Explorer

When I change the default browser to either IE7 or FireFox the program associations above change to the correctly.  When setting Seamonkey as default the program associations do not change!!!  

Comment 3

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.13) Gecko/20080313
SeaMonkey/1.1.9
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008050802 SeaMonkey/2.0a1pre

This problem still persists.
Possibly related: bug 376465, bug 413876.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: SeaMonkey 1.1 Branch → Trunk
To bug opener and all problem reporters:
Is same phenomenon/problem/cause as Bug 442110 involved in your problem on Vista?
(Bug 442110 is reports for Seamonkey on MS Win-XP SP2) 

Comment 6

11 years ago
I had to reinstall Vista and now SeaMonkey is set as my default browser. Also the following protocals

FTP             URL:File Transfer                       
GOPHER          URL:GOPGHER Protocal                                 
HTTP            URL:HyperText Transfer Protocol         
HTTPS           URL:HyperText Transfer Protocol with Privacy

are all now set to SeaMonkey.

Updated

10 years ago
Assignee: general → installer
Component: General → Installer
QA Contact: general → xpi-packages

Comment 7

10 years ago
See Comment #6, I close this for now as wfm.
Reporter, if you still run into this problem while using an recent Build,
please reopen and submit actual information.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.