www.bluesnews.com causes crash

VERIFIED WORKSFORME

Status

()

Core
Networking
P3
critical
VERIFIED WORKSFORME
18 years ago
16 years ago

People

(Reporter: Jeremy M. Dolan, Assigned: jst)

Tracking

({crash, testcase})

Trunk
x86
All
crash, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
experiancing w/ jun 12 M17.

crash at about 50% of page downloaded...

*** check number of frames in content area 
Error loading URL http://www.bluesnews.com/ 
WEBSHELL+ = 5
WEBSHELL+ = 6
*** check number of frames in content area 
./run-mozilla.sh: line 29: 19471 Segmentation fault

Someone wanna sic a debug build on this?

Comment 1

18 years ago
Confirmed with 061314 (M17) on Linux.  Changing severity due to crash, and
adding keyword.  This could use a more minimal testcase.

The offending URL is actually http://www.bluesnews.com/news/news.shtml
Severity: major → critical
Keywords: crash
(Reporter)

Comment 2

18 years ago
Ye ask and ye shall receive... +makingtest
Keywords: makingtest
(Reporter)

Comment 3

18 years ago
This is M17 only, all platforms.
OS: Linux → All
(Reporter)

Comment 4

18 years ago
Accessing this page via file:, or via http: at my domain works fine. Images get
loaded and everything.

bluesnews.com: Apache/1.3.9 (Unix) mod_perl/1.21 PHP/3.0.12 on Linux
my server:     Apache/1.3.9 (Unix) PHP/3.0.14 on Linux

W/9X reports this is dieing in module JS3250.dll. If thats javascript, it's
interesting, cause theres no script on this page at all. Can't create a test
case, taking a guess at component... -> Networking.
Component: Browser-General → Networking
Keywords: makingtest

Comment 5

18 years ago
That's funny, loading it off of my disk makes it crash.  I'll try to reduce it.

Comment 6

18 years ago
Removing the doctype makes the crash go away.  I assume this is related to the
recent landing of the strict dtd fu.

Comment 7

18 years ago
Created attachment 10099 [details]
Simplified testcase

Comment 8

18 years ago
I downloaded the page with "telnet www.bluesnews.com 80" :-)

Apparently js code does some document.write() to create a <SCRIPT> paragraph
(inside another <SCRIPT>).

Note: there was a URL ad in this additional SCRIPT paragraph, I replaced it
with a mozilla banner gif in the attached testcase.

Comment 9

18 years ago
Reproduced on PC/Linux with build 2000061314. The stack traces of all these
examples seem to indicate an uncontrolled recursion:
  JS -> libraptorhtml.so -> libraptorhtmlpars.so -> libraptorhtml.so ->JS

Comment 10

18 years ago
any ideas on who should get this?
if this is doctype related, rickg should get it.
Bug 42624 (crash on www.catia.com) is a dup of this one. Can someone take a look
at that page and find the javascript there that causes this?

Maybe it would help if someone with a sufficiently new M17 build with
non-stripped libraries could take a stack trace first. That would give us more
info about what's going on.

Comment 13

18 years ago
*** Bug 42624 has been marked as a duplicate of this bug. ***

Comment 14

18 years ago
Adding testcase keyword
Keywords: testcase
jst, it this yours? reassigning.
Assignee: asa → jst
win98, 200061608, no crash. Anyone still seeing this?
(Assignee)

Comment 17

18 years ago
I can't reproduce this crash nor the www.catia.com crash, marking WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 18

18 years ago
www.bluesnews.com and www.catia.com, as well as the 2 testcases, WFM
with 2000-06-17-08 on Linux.

Comment 19

16 years ago
reporter:

This bug is a "futured" or "untargeted" bug which has been "resolved/works for
me". Most bugs meeting this criteria are usually somewhat out of date or working
in the current builds.

If this bug is not happening for you in a recent build (such as the Mozilla
daily build, Mozilla 0.9.3, or Netscape 6.1), please use the friendly "Mark bugs
as VERIFIED" radio button to set this bug to "VERIFIED/WORKS FOR ME"
If you reported the bug on a platform (e.g. Linux) and other contributors
reported on another platform (e.g. Mac OS), please comment that it works for you
 but do not verify it yet.

For these multi-platform bug reports, we need to verify all reported platforms
-OR- create new "still broken on platform X" bugs when you verify.
(Reporter)

Comment 20

16 years ago
testcase and site don't crash, v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.