Replace languages icon (currently UN icon)

RESOLVED FIXED in Firefox 3

Status

()

Firefox
Theme
P2
normal
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: u88484, Assigned: faaborg)

Tracking

({polish})

Trunk
Firefox 3
polish
Points:
---
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments, 3 obsolete attachments)

(Reporter)

Description

10 years ago
The languages icon needs changed, the world icon without location specific identifiers was the best choice by far.  The new UN icon is by far the worst possible choice.  Not every country is part of the UN, many hate nations that are in the UN, peoples relatives by possibly been killed or their lives destroyed by UN peacekeeping missions and the list goes on.
Flags: blocking-firefox3?
(Reporter)

Comment 1

10 years ago
Created attachment 311037 [details]
Screenshot
(Reporter)

Updated

10 years ago
Target Milestone: --- → Firefox 3
Flags: blocking-firefox3? → blocking-firefox3-
Axel: thoughts?
As a data point, OS X and I believe GNOME use UN imagery as well.  Mind you, OS X also uses flags...
(Don't people who hate nations that are in the UN _probably_ hate nations that are on the world too?  Where people have died for millennia?)

Comment 5

10 years ago
(In reply to comment #4)
> (Don't people who hate nations that are in the UN _probably_ hate nations that
> are on the world too?  Where people have died for millennia?)
> 
But unlike with the UN, everyone is a member of the world.  And, on rechecking, it looks like the globe icons are even careful to center on an ocean with nondescript continents around the edges, so no particular region is promoted.
(Reporter)

Comment 6

10 years ago
I was just making a point ;)  But still, people don't like the UN, don't
recognize it, maybe even get Firefox banned in some countries like Iran that
despise of the UN.

I hear people talking about hating the UN and UN destroying their lives by
either accident of by no action at all but not about hating the world because a
volcano exploded or their friend died in the ocean or something to that effect.

There is just no point to use an organization's identifiable mark as an icon in
a program.

Comment 7

10 years ago
The old globe icon wasn't perfect, but it was much better than using the UN flag. For all the reasons stated above, the UN flag SHOULD NOT be used as an icon in Firefox.  Besides, it doesn't even look right with the other icons. It is just out of place.
Created attachment 311049 [details]
Proposed replacement

Comment 9

10 years ago
Justin,

Your proposed replacement would work great as long as someone came up with a Klingon language pack. :-p

Comment 10

10 years ago
Is there a bug or something with a rationale for the UN icon?

Comment 11

10 years ago
Axel,

I'm not sure what you are asking with your question, but the point of this bug post is that using the UN flag for the language button is inappropriate for all of the reasons posted above.  The icon should be reverted to the old politically neutral globe icon until a better idea can be come up with.

Comment 12

10 years ago
I don't think that hate is a great argument. That's why I'm trying to understand the rationale for having the UN flag there.

To me, the small blue thing with white stuff on it doesn't hint at languages. I don't have any constructive suggestions, which is why I'm interested in the original discussion leading to this choice.
(Reporter)

Updated

10 years ago
Duplicate of this bug: 425023
(Reporter)

Comment 14

10 years ago
From dupe 425023:

The add-ons manager uses the United Nations flag. See
http://www.un.org/depts/dhl/maplib/docs/stsgb132.pdf , especially chapter IV,
abstract c).

(Reporter)

Comment 15

10 years ago
There is more than enough reasons right there to remove it and probably immediately.

Comment 16

10 years ago
It is worth noting Microsoft uses a globe for their Regional and Languages control panel.
How about a speech bubble with a globe inside?

Comment 17

10 years ago
From the UN regulations referenced above:

==begin quote==
IV. PROHIBITIONS
(a) In accordance with article 7 of the United Nations Flag Code on no account shall the United Nations Flag or a replica thereof be used for commercial purposes or in direct association with an article of merchandise;
==end quote==

There you go, the UN flag icon MUST go, there is no choice in the matter. Firefox is a commercial product.
Renominating (non-beta); this feels like a trademark-respect issue, and I think we should remove it, as we would want people to not use Firefox logo to mean "browser" in a desktop distro.
Flags: blocking-firefox3- → blocking-firefox3?
Created attachment 311643 [details]
un-UN viewButtons.png v.1
Attachment #311049 - Attachment is obsolete: true
Created attachment 311644 [details]
un-UN viewButtons-aero.png v.1

This takes care of Windows. Pinstripe just uses a globe, and Gnomestripe's icon is a flag that may-or-may-not look like the UN flag, and the Tango team can update that if needed (too hard for me).
Ah, UFP. Always the saviours.
Flags: blocking-firefox3? → blocking-firefox3+
Priority: -- → P2
Team Penguin: heads up!
(Reporter)

Comment 23

10 years ago
(In reply to comment #16)
> It is worth noting Microsoft uses a globe for their Regional and Languages
> control panel.
> How about a speech bubble with a globe inside?
> 

This seems to me to be a much better idea for a replacement than the UFP flag.  What was wrong with the non-location oriented globe anyways?
The UN flag like icon was chosen because it is the nearest thing to a "planet earth" flag we have. The world is big and I'm sure fore every icon used there is a person somewhere who will be offended by it because he/she sees some offending national/religious/etc symbol hidden in it. You know the Pidgin¹ instant messenger? Take a look at the logo font. Someone actually filed a bug complaining about pidgin being a satanist tool, because the logo includes "666".

The quote from #17 seems to be related to using the logo to sell stuff (t-shirts etc). I doubt Apple would use it for language settings if there were any legal problems with that. The proposed replacement is much worse in this regard as Paramount is not exactly known let people use their trademark.

So the options I see are a) keeping the UN flag or b) using a globe icon. Using b would mean we had to use a non-earth globe (as people could feel offended by their country/continent not being visible), which in turn would destroy the metaphor (how many non-earth languages are supported by mozilla?).

Needless to say, both GNOME and KDE will keep using the UN flag, so most Firefox users on Linux will already be offended by the Desktop Environement itself...

[1] http://pidgin.im/
Created attachment 311663 [details]
un-UN-flag buttons v2

no flag
Attachment #311663 - Flags: approval1.9b5+
Created attachment 311664 [details]
un-UN-flag buttons v2

no flag
Attachment #311643 - Attachment is obsolete: true
Attachment #311644 - Attachment is obsolete: true
Attachment #311664 - Flags: approval1.9b5+
(Reporter)

Comment 27

10 years ago
So now a blue box?  It just keeps getting worse guys.
For now, on winstripe, please check in the two no-flag icons as viewButtons.png and viewButtons-aero.png and we'll ship winstripe in b5 with a blue square. We can figure out what to do later, leave the bug open.
Assignee: nobody → faaborg
(In reply to comment #27)
> So now a blue box?  It just keeps getting worse guys.

Boo-hoo. It was pointed out the UFP thing was no better from a copyright violation perspective, so this is what you get for this pass. We'll fix it for final.

Only actual submissions of suggestions of better icons should be accepted. The issues around this bug are clear. We either decide that we like the UN metaphor enough to contact them and get permission, or we change it.
Keywords: checkin-needed
(Reporter)

Comment 30

10 years ago
I was too quick at posting before your explanation posted and thought that was what was being proposed for final.  At least it is temporary.

Comment 31

10 years ago
Instead of using a blue box placeholder, for now the icon should be returned to the old globe icon.  The old icon is a heck of a lot better than the proposed placeholder.
Checking in toolkit/themes/winstripe/mozapps/extensions/viewButtons-aero.png;
/cvsroot/mozilla/toolkit/themes/winstripe/mozapps/extensions/viewButtons-aero.png,v  <--  viewButtons-aero.png
new revision: 1.3; previous revision: 1.2
done
Checking in toolkit/themes/winstripe/mozapps/extensions/viewButtons.png;
/cvsroot/mozilla/toolkit/themes/winstripe/mozapps/extensions/viewButtons.png,v  <--  viewButtons.png
new revision: 1.8; previous revision: 1.7
done
Keywords: checkin-needed

Comment 33

10 years ago
Some ideas for a replacement of the boring blue block:
Another way of showing 'speech': http://www.linkmatrix.de/x/048x048-languages.png
Free speech flag: http://www.badmouth.net/free-speech-flag/
Using a country neutral flag: http://www.trackstarreunion2008.co.uk/images/Misc/ChequredFlag2.JPG
Synbolized flag: http://commandshift3.com/images/flag.png
Plain flag: http://www.qipit.com/themes/qipit/img/public/flag.png
(Assignee)

Comment 34

10 years ago
>Is there a bug or something with a rationale for the UN icon?

Sorry for the lag in replying, the UN flag was selected after being proposed by the tango team, for the reasons in comment #24.  As other people have noted it is also currently used in OS X.  
(In reply to comment #33)
> [lips]
The language tab is about written language, not spoken... Also, showing body parts would violate the GNOME (and Apple?) HIG.

> Free speech flag
This is not related to language and I'm not sure how many people actually recognize it...

> Using a country neutral flag
Again, the UN flag is perhaps the most neutral flag that is still connected with a lot of countries/languages. Using a flag that is not related to countries/languages misses the whole point.

> Synbolized flag
same as above. this shape in particular reminds me of a very similar image often used by some political parties on their advertising papers...

> Plain flag: http://www.qipit.com/themes/qipit/img/public/flag.png
also same as above. the shape looks like the windows logo...

Comment 36

10 years ago
My original idea was for a picture of a globe with a speech bubble coming out of it. But as you said, this is written language and not spoken. Though I can;t think of anything else that would fit the metaphor and still follow HIG and have good i18n.
(Reporter)

Comment 37

10 years ago
(In reply to comment #36)
> My original idea was for a picture of a globe with a speech bubble coming out
> of it. But as you said, this is written language and not spoken. Though I can;t
> think of anything else that would fit the metaphor and still follow HIG and
> have good i18n.

Paper and pencil with the paper having alternating pixels up and down to represent text?

Comment 38

10 years ago
I think a speech bubble represents written language fairly well. I know it's supposed to symbolize speaking, but it's also highly associated with comics, and is the written representation of speaking. My quick searching around also leads me to believe that this is a pretty international symbol, used in comics everywhere.

Comment 39

10 years ago
A globe with speech bubble makes a heck of a lot more sense than any other suggestion I've seen here. 

Comment 40

10 years ago
the OLPC project seems to use some kind of speech-flag with globe icon
http://wiki.laptop.org/images/thumb/8/8e/Translate7.svg/84px-Translate7.svg.png

Comment 41

10 years ago
With these kind of considerations (icon x may offend the y guy) we should just remove most of the icons (which is fine for me since it would streamline the ui). Regarding the "trademark issue" as in comment #17 that's not our case (linux) since we're not really replicating the UN flag but it's just really something that vaguelly resemble it. It can be the UNICEF flag alse, so if you don't like the UN consider it like that :-)
Anyway if you really REALLY want to change that icon, I'd just remove the logo from the center and use a plain blue flag.
Re "speech bubble": it is commonly used for "chat" already
(Assignee)

Comment 43

10 years ago
Changing the summary from revert to replace, since we are not going to go back to the Firefox 2 icon either way, but will be creating a new icon based on what we decide.

Personally I'm against compound icons, like an hour glass, a shield and a green check mark next to a computer with a bug on the screen.  Regardless of what we decide, I would like it to be a single symbol or metaphor.

Worst case scenario when you can't think of a good metaphor just show a picture of the entire planet :)
Summary: Revert languages icon (Replace UN icon) → Replace languages icon (currently UN icon)

Comment 44

10 years ago
IMO, a flag makes no sense at all. Flags are for nations, not languages. The UN is an acronym for United Nations and not United Languages. Most(?) nations have several official languages (majority and minority). For all I know, the only language that has a flag is Esperanto. 

And from a linguistic POV, written language is basically representation of spoken language. Therefore I think a speech bubble is the best possible solution. 

I think Michael Monreal's point above is somewhat valid, that speech bubbles are commonly associated with chat apps. But you could probably dismiss every single icon by associating it with earlier uses. 

Of all the suggestions above, I think the speech bubble is the best one. Throw in a globe there too if it's necessary. Whether you like compound icons or not, there are a few in FF3 already. 
(Assignee)

Comment 45

10 years ago
Since we need a decision quickly, here we go: I think on Windows we should go with a globe constructed of latitude and longitude lines, with no continents.  OS X and Linux are free to create a similar icon, or to use an icon similar to the native platform (which in both cases is a flag reminiscent of a UN flag).
Decision in comment 45 gets my ui-r+

Comment 47

10 years ago
Created attachment 314540 [details]
Sample globe constructed with lines (from Apple's site used to denote languages)

Attached a sample globe made with lines as found in apple's website.
(Assignee)

Comment 48

10 years ago
Created attachment 314545 [details]
Generic M class planet

Changed my mind on the apple design (why do they curve their latitude lines?)  Here is a draft of the globe the iconfactory made for us, I asked them to generate some random continents so as not to upset anyone.
(Reporter)

Comment 49

10 years ago
(In reply to comment #48)
> Created an attachment (id=314545) [details]
> Generic M class planet
> Changed my mind on the apple design (why do they curve their latitude lines?) 

Because Earth isn't flat ;)  and probably to keep it from looking like a grid overlay on the planet.

(Assignee)

Comment 50

10 years ago
>Because Earth isn't flat ;) 

long day, why do they curve their latitude lines way more than their longitude lines?  What kind of non-spherical planet does apple think we are living on?  Pretty though.

Comment 51

10 years ago
I bet they included the gravitational distortion due to the goldmine they're sitting on.
(Reporter)

Comment 52

10 years ago
haha that's great!  Alex, FWIW the generic M class planet icons look great to me.
Comment on attachment 314545 [details]
Generic M class planet

Alex, can you provide the new file for the options window icons with this file in it? When you do, just mark it with approval1.9?
Attachment #314545 - Flags: ui-review+
(Assignee)

Comment 54

10 years ago
>Alex, can you provide the new file for the options window icons with this file
>in it? When you do, just mark it with approval1.9?

All of the icons are going to land in one big drop, since attaching them individually to all of the various bugs would take too long.  I'll go back and resolve this bug after the new icon has landed.
You need to log in before you can comment on or make changes to this bug.