Junk folder should be sorted by spamminess, not Subject/Sender/Date

RESOLVED DUPLICATE of bug 209890

Status

--
enhancement
RESOLVED DUPLICATE of bug 209890
11 years ago
11 years ago

People

(Reporter: bob.lord, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
From http://sethgodin.typepad.com/seths_blog/2008/03/alphabetical-or.html
===
I love the alphabet and the fact that it has an order. There's no reason for the order of the letters, but there you go.

With computers, though, alphabetical order is almost always a bad idea, even chronological order doesn't work perfectly.

Example: When I look through my spam folder, I shouldn't see the notes in chrono order or alphabetical by sender (with AAAA' going first...). No, I should see the notes in order of least likely to be spam to most likely. Right? (book tip: Everything is Miscellaneous).
===

So this is an RFE to add a new column called something like "Junk Rating" that shows me just how likely a particular message is to be spam.  An even more aggressive approach would be to remove many/all of the other columns and just focus on the junk rating since people tend not to need things like threading when reviewing spam.

Comment 1

11 years ago
Bug 366491, soon to be complete, adds enough for this to be done with an extension.

Updated

11 years ago
Depends on: 366491
OS: Windows Vista → All
Hardware: PC → All

Comment 2

11 years ago
At this point, the question is whether this column is desired in the core product, or left to an extension. This functionality can now be added in an extension. In any case, bug 209890 is the main place this issue is being discussed.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 209890
You need to log in before you can comment on or make changes to this bug.