When tbody overflow is scrollable and borders are collapsed: borders remain fixed and don't scroll; borders and cell background flow out of table

RESOLVED DUPLICATE of bug 135236

Status

()

Core
Layout: Tables
RESOLVED DUPLICATE of bug 135236
11 years ago
10 years ago

People

(Reporter: Michael Fayez, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows Vista
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US) AppleWebKit/525.13 (KHTML, like Gecko) Version/3.1 Safari/525.13
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b5pre) Gecko/2008032204 Minefield/3.0b5pre

apply style overflow-y: auto and setting height to fixed value the rules lines doesnt scroll with table cells and rule lines flow out of the table to the original height of the table without height attribute set to the tbody element



Reproducible: Always

Steps to Reproduce:
1.prepare table with tbody, thead and tfoot elements and set rules to any value other than none
2. apply style to tbody overflow-y:scroll;height 30px; 
3. add rows in the tbody elements enough to make tbody scroll
Actual Results:  
rules lines are fixed on the page and dont scroll when scrolling tbody rules flow out of table to the original height of the table without height attribute set to the tbody element

Expected Results:  
rules lines scroll when tbody scrolls
rules dont flow out of table
(Reporter)

Comment 1

11 years ago
Created attachment 311194 [details]
the file demonstrates the bug of rules
(Reporter)

Comment 2

11 years ago
this is an old bug that affects Firefox 2
Created attachment 327488 [details]
Minimal Testcase - from testcase #1

Confirmed. I created a minimal testcase. I report here what I written also in the testcase:

Table borders remain fixed even when the scrollbar is moved, and borders continue to be drawn even after the table is finished under it, as reported.

This happens when table has border-collapse: collapse, and tbody has overflow-y: auto and a fixed height. This bug happens also if table has not border-collapse: collapse, but has rules="all" attribute. The bug does not happens if there's no tbody element, as reported.
Attachment #311194 - Attachment is obsolete: true
Confirmed on trunk and on Fx2, WinXP. Need to be confirmed on Linux and Mac.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: qawanted, testcase
Whiteboard: [reproducible on Linux and Mac?]
Version: unspecified → Trunk
Summary: when tbody is scrollable rules lines are fixed and dont scroll and flow about table element → When tbody overflow is scrollable and borders are collapsed, borders remain fixed and don't scroll, and flow out of table
Flags: wanted1.9.1?
Flags: blocking1.9.1?
Created attachment 328189 [details]
Minimal Testcase #2: cell bacground

New problems found from Bug 440080. Also the background flow out the page, and has other strange behaviours. A better description is inside the testcase.
Attachment #327488 - Attachment is obsolete: true
Depends on: 317137, 439639
Summary: When tbody overflow is scrollable and borders are collapsed, borders remain fixed and don't scroll, and flow out of table → When tbody overflow is scrollable and borders are collapsed: borders remain fixed and don't scroll; borders and cell background flow out of table
What happened to searching for duplicates before confirming?
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 135236
No longer depends on: 317137, 423823, 439639
Flags: wanted1.9.1?
Flags: blocking1.9.1?
Keywords: qawanted
Whiteboard: [reproducible on Linux and Mac?]
You need to log in before you can comment on or make changes to this bug.