when setting the table syle to border-collapse:collapse and tbody to fixed height and overflow-y:auto and all rows are invisible in the tbody the table has a big height than the height specified of the tbody

RESOLVED WORKSFORME

Status

()

Core
Layout: Tables
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Michael Fayez, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US) AppleWebKit/525.13 (KHTML, like Gecko) Version/3.1 Safari/525.13
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b5pre) Gecko/2008032204 Minefield/3.0b5pre

when setting the table syle to border-collapse:collapse and tbody to fixed height and overflow-y:auto  and all rows are invisible in the tbody the table has a big height than the height specified of the tbody


this is an old bug of firefox 2.0

Reproducible: Always

Steps to Reproduce:
1.create a table with style border-collapse:collapse
2.add tbody to that table with style:heigth:any height;overflow-y: auto;
3. add any number of rows greater than zero to tbody on conditio that all these rows have style display:none;
4. add tfoot to this table
Actual Results:  
there is a huge space between thead and tfoot and greater than  the height specified in the tbody

Expected Results:  
there should be a space between thead and tfoot with the height specified in the style of tbody
(Reporter)

Comment 1

10 years ago
Created attachment 311200 [details]
testcase
It works for me with:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a1pre) Gecko/2008062703 Minefield/3.1a1pre

Can you install the latest beta ( http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/ ) and test this bug in safe mode, or better with a blank profile? Disable also temporary all plugins.

If it works in this way, but not with your normal profile, probably it's a problem caused by an extension. So try to disable them one-by-one. 

When you find the problematic extension(s), inform us and its author.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.