Task dependency, hierachy/tagging, gant chart view, integration, bugzilla integration [extension fodder]

VERIFIED INVALID

Status

--
enhancement
VERIFIED INVALID
11 years ago
8 years ago

People

(Reporter: 0x0065, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en_GB; rv:1.8.1.11) Gecko/20080222 Firefox/2.0.0.11
Build Identifier: n/a

This is about Thunderbird becoming best in it's class: A feature that makes decision makers in large companies immediately see an answer to the 'so what' question. One that relates directly to _their_ day to day activities.

The task list in 'that other e-mail client' (that you may have never been forced to use) is effectively a raw, rough & ready front end to an LDAP(ish) database. It has never realised it's full potential, probably due to it's userbase & developers...

A task list in a project management application (I'm an Architect, not a project manager. I'm not sure which you feel is worse.) needs to:

- connect to resources (people and their available time, hardware, places, etc.)
- it needs to know about task dependency, in order to find the 'critical path'... ...that pathway through the project's tasks that is setting the completion date. (this is something VERY important and BIG money related that 'the other e-mail client' doesn't do)
- it needs to give immediate feedback about the consequences of changes to tasks on the 'critical path' because project managers often have questionable work ethics, (not to mention intellect).
- maybe not the best way, but the standard way to get an overview of the information above is a gant chart.
- Heirachy of tasks is really essential for large projects. This can be integrated into gant chart views. If they could relate to tags/categories and/or to easily made searches somehow, that would be superb. (this is something important that 'the other e-mail client' doesn't do very well)
- Subtasks in one branch of a heirachy need to be made dependent on subtasks in a separate branch. That is reality. (this is something very important that 'the other e-mail client' doesn't do)
- It would be superb if tasks dependency could link between projects (eg. If my concreters take another week on Project A, the resultant delay on Project B will be on the critical path...) Again the project division could be a tagging thing, similar to sub-tasks
- Once the LDAP bit is set up properly, the client side needs to 'just work' for a grey haired guy with a US$400++ shirt & an hourly charge out rate that'd make your eyes water. 'Just working' as a stand alone would be good for small business.
- It would be superb if correspondence & briefing documents could be cross-referenced from tasks. This isn't critical. Attaching them would be sufficient.
- Being able to easily print out shiny colour prints/pdfs (split over multiple A0 pages) of the gant chart view will be their next question, but once it's in a pretty standard sort of LDAP database, a different client could be used to do non-manager related stuff.

The integration with calendars & mail is what will sell this over the status quo. There needs to be a way to turn off task & meeting updates while open heart surgery is being done on the critical path of a project program.

Wouldn't it be nice if it tied into bugzilla or something, with a triage/unassigned area in a project for new bugs/tasks/requests for information/instructions with a nice shiny right click menu & a preview pane?

Do that well & I predict the construction industry (among others) will worship you.

Are you still reading? I'll stop now. It's dinner time.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Updated

11 years ago
Depends on: 341230
Two comments:

1. This bug is INVALID because you mix up too many things into one bug. We have 
   a rather strict "one issue per bug" policy in bugzilla that helps us getting
   things done. 
   You won't get things done if you lump everything together into one bug. 
   Please file new bugs for each individual issue, but search for duplicates 
   first (some issues have already been filed (e.g. Gantt charts in bug 182558)

2. I predict that most or all of those bugs will be resolved as WONTFIX. 
   Thunderbird (with or without Lightning) are not and will not be a full-blown 
   project management tool, that you want them to be. The vast majority of our 
   users do not need and do not want this kind of functionality.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

11 years ago
Given that clicking on an http:// link doesn't even do anything anymore, perhaps talking to you about the value of integration is a little wasted.

1. I note bug 182558 has already been marked wontfix/don't understand.

2.I take this to mean you view thunderbird as something unsuitable for an enterprise environment. The project management part is a side effect of an average employee knowing what they are doing today, & being able to 'manage up'/'push back early' when their task list doesn't engage with reality. Is there a reason that full task support can't be an extension in much the same way as lightning?

ja na
(In reply to comment #2)
> 1. I note bug 182558 has already been marked wontfix.

Exactly. Lightning/Sunbird are not project management tools, but tools for calendar/task management.

> 2.I take this to mean you view thunderbird as something unsuitable for an
>   enterprise environment.

Quite the contrary, Thunderbird is perfectly suitable for an enterprise 
environment, but that does not mean that it must be an adequate project management tool.

> The project management part is a side effect of an average employee knowing 
> what they are doing today, & being able to 'manage up'/'push back early' 
> when their task list doesn't engage with reality.

This functionality is already possible with Lightning.

> Is there a reason that full task support can't be an extension in much the 
> same way as lightning?

Absolutely not. Instead I would absolutely recommend to implement such 
functionality in an extension and not in the base product Thunderbird directly.
(Reporter)

Comment 4

11 years ago
(In reply to comment #3)
> Quite the contrary, Thunderbird is perfectly suitable for an enterprise 
> environment, but that does not mean that it must be an adequate project
> management tool.

Enterprise calendaring and tasks management is what? It is the principal project management tool of most enterprise employees. It could be the definitive project management tool. You keep emulating first violin from the second fiddle seat though. It's worked well for you so far.

> > The project management part is a side effect of an average employee knowing 
> > what they are doing today, & being able to 'manage up'/'push back early' 
> > when their task list doesn't engage with reality.
> This functionality is already possible with Lightning.

Rubbish. The existing functionality you talk about is implemented in jellyware... ...that's somewhere rather like your imagination. The program is in managers copy of Microsoft Project. It's distributed in hard copy. If the tasks are entered into 'the mail client', it's by the do-ee & they have no link to push back through. Nobody sees the problems because your calendaring & tasks are too limited to be worth the data entry time for anything more complex than a meeting schedule & to-do list.

> ...I would absolutely recommend to implement such 
> functionality in an extension and not in the base product Thunderbird directly

Then why are you marking things as wontfix you wakka? Do you loose brownie point s for open feature requests?

Incidentally, listing these points as individual tasks without an overarching task to explain the point to it all would make it even easier for you to miss the point. Maybe that's why all your feature requests get marked wontfix.

Imagine you are in a team with 20 others working on a range of tasks as you come free. The project manager is in another world & really just looks at THEIR program (which will obviously not be thunderbird any time soon) before the Monday morning meeting. Well that's the end of it right there. You really don't get it do you? These people decide what software is ALLOWED in THEIR office. If they're using Microsoft Project, it's not you anyway is it? If it's a full web bizzo, then it's not you either.

Sounds like bug triage in the all new shiny Thunderbird (set to challenge the world with wizzie bang good stuff) is much the same as it was.
(In reply to comment #4)
>> ...I would absolutely recommend to implement such functionality in an 
>> extension and not in the base product Thunderbird directly
>
> Then why are you marking things as wontfix you wakka? Do you loose brownie
> points for open feature requests?

1. This is the bug-tracking system for the Thunderbird base product. We do not 
   track bugs for extensions here.
2. This discussion is now over, since you do not seem to be able to respect 
   the views of others and have started a name-calling business. Please do that 
   somewhere else!
Summary: Task dependency, hierachy/tagging, gant chart view, integration, maybe bugzilla integration? → Task dependency, hierachy/tagging, gant chart view, integration, bugzilla integration [extension fodder]
(Reporter)

Comment 6

11 years ago
(In reply to comment #5)
> 1. This is the bug-tracking system for the Thunderbird base product. We do not 
>    track bugs for extensions here.
Say! wouldn't it be *SWEET* if you could just drag the bug across to extensions, instead of having to wontfix everything.
> 2. This discussion is now over, since you do not seem to be able to respect 
>    the views of others and have started a name-calling business. Please do that 
>    somewhere else!
When was this a discussion. Look who's talking. *(^u^)*. So already gone after your first response.
(In reply to comment #6)
> Say! wouldn't it be *SWEET* if you could just drag the bug across to
> extensions, instead of having to wontfix everything.

There is no such component, nor do I see the point of one. It's just not the way to make it would go anywhere... If you want it, implement it yourself, or find someone in some extension forum that wants to do it.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

11 years ago
(In reply to comment #7)
> There is no such component, nor do I see the point of one. It's just not the
> way to make it would go anywhere... If you want it, implement it yourself, or
> find someone in some extension forum that wants to do it.

Said Magnus the Thunderbird developer, as he typed correspondence about a task into his web browser (the irony clearly lost on him).

マジで!!! I thought this conversation was over. There are other project's actually engaging with, and making strides towards resolving these clear and manifest failings in productivity software. Can I delete this account?

*rofl* (^-^) Excuse me while I go to try & use this web portal to change my contact details in your address book. (^-^)

Seriously! you are so 'web = internet' for people who make non-web clients.

No longer depends on: 341230
You need to log in before you can comment on or make changes to this bug.