'Sort by name' produces unexpected behavior on tag containers




Bookmarks & History
10 years ago
8 years ago


(Reporter: Damian Shaw [Quan], Assigned: mano)


Firefox 3
Bug Flags:
blocking-firefox3 -

Firefox Tracking Flags

(Not tracked)




10 years ago
Make sure you have tags and follow these instructions, do NOT go to the places library, it seems to work o.k there

1. Go to bookmark toolbar
2. Click on Smart Bookmarks
3. Click Recent Tags
4. Right click on a tag category
5. Click sort by name
6. A tag disappears 
7. Other things seem to happen, like sometimes it uses the page title to display the name, other times it doesn't

Not sure this can be fixed till bug 419731 is though
Flags: blocking-firefox3?


10 years ago
Depends on: 419731
Mano: pretty sure that this is a dupe, and that you're already looking at this.
Flags: blocking-firefox3? → blocking-firefox3+
Priority: -- → P2
Whiteboard: DUPEME

Comment 2

10 years ago
Well it's very similar to bug 420003 but I was told not to reopen that bug.


10 years ago
Assignee: nobody → mano

Comment 3

10 years ago
(In reply to comment #2)
> Well it's very similar to bug 420003 but I was told not to reopen that bug.

I have never seen this before (but I was working on "Sort by Name") and I can reproduce it now. So I may be the right one to fix it.

Comment 4

10 years ago
if bug 419731 lands tag container contents will be sorted by name by default, and being a query the Sort By Name option will not be there

Comment 5

10 years ago
Ignore step 7 from comment #0 this is actually bug 424669
OS: Windows XP → All
Hardware: PC → All
Whiteboard: DUPEME → [patch in bug 419731]
Target Milestone: --- → Firefox 3


10 years ago
Whiteboard: [patch in bug 419731] → [has patch in bug 419731]

Comment 6

10 years ago
actually we can't sort tag containers content by design due to the need of having fast dupe filtering of contents (see bug 419731).
we should change the underlying impl to move tags to a separate table (this should help solving duplication perf)

You can temporary sort tag contents in the Library, but no permanent sorting is provided.

So, this should not be a blocker anymore.
Whiteboard: [has patch in bug 419731]
Agreed with Marco.
Flags: blocking-firefox3+ → blocking-firefox3-

Comment 8

10 years ago
Connor: This has actually been fixed as far as I can see.

You now no longer get an unexpected behavior. Was fixed by bug 419731.
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 9

10 years ago
well, i'm not sure this is fixed since removing a functionality is not a fix for sure, better invalid probably and a new bug open to restore sort by name functionality on tag containers in future


10 years ago
Resolution: FIXED → INVALID
filled bug 429686
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.