New Message Filters are not saved

RESOLVED DUPLICATE of bug 362539

Status

--
major
RESOLVED DUPLICATE of bug 362539
11 years ago
8 years ago

People

(Reporter: pjah, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: 2.0.0.12

newly created message filters are gone after TB is restarted. 

Reproducible: Always

Steps to Reproduce:
1. Create a new message filter in TB via Tools> Message Filters> new 
2. Filter runs successfully against mail folder. 
3. shutdown/restart of TB filters are gone. 
Actual Results:  
newly created filters are lost. 

Expected Results:  
newly created filters are retained across TB restarts. 

1. This is occurring on Windows 2K3 Terminal Server, 32-bit. 
2. This is occurring for ALL users of TB on the WinTS. 
3. We are running only IMAP (local folders are used only for "Drafts")
4. C:\Documents and Settings\<userid>\Application Data\Thunderbird\Profiles\rf51yxyt.default\ImapMail\<imap-profile-name>
shows time-stamp of msgFilterRules.dat as very old, yet filterlog.html is reasonably current
DUP of 362539? Check Temp directory content. (You can see temp directory path/content by 'SET TEMP', 'SET TMP', DIR %TEMP% /S, DIR %TMP% /S, at Command Prompt)

> 2. This is occurring for ALL users of TB on the WinTS.

Network file is used?
(AFAIK, data loss problems due to bug of network file system are reported sometimes to bugzilla.mpzilla.org)

New problem after upgrade of Thunderbird?
Or problem since initial use of Thunderbird?
Recently appeared problem even though no change of Thunderbird? 
Oh sorry, not linkified. DUP of Bug 362539?
(Reporter)

Comment 3

11 years ago
(In reply to comment #1)
> DUP of 362539? Check Temp directory content. (You can see temp directory
> path/content by 'SET TEMP', 'SET TMP', DIR %TEMP% /S, DIR %TMP% /S, at Command
> Prompt)
> 

I accept that this is likely a DUP of 362539 - thank you for your help! - although the symptoms are not exactly the same: 
1. In my case, doing a RUN on the new filter rules worked (I believe I read that  in case 362539 the RUN did not work)
2. I _did_ have 10000 tmprules*.dat sitting in the %TEMP% directory.  Deleting these _did_ resolve the problem and my new rule now is saved across TB restarts.
3. BTW - TB startup is much faster now that the 10000 files are gone.

> > 2. This is occurring for ALL users of TB on the WinTS.
> 
> Network file is used?

No -- all files are local. (We will be implementing a SAN shortly - do I need to worry about this?) 

> (AFAIK, data loss problems due to bug of network file system are reported
> sometimes to bugzilla.mpzilla.org)
> 
> New problem after upgrade of Thunderbird?

We are pretty current with TB releases.  It seems that this problem started happening after we upgraded from some earlier release but I can not be certain.
Maybe it was when we went from TB 1.x to 2.0.

> Or problem since initial use of Thunderbird?

Message filters were working when we installed TB 1.x

> Recently appeared problem even though no change of Thunderbird? 
> 

Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 362539
You need to log in before you can comment on or make changes to this bug.