Empty inline elements are not affecting the inline box model as per spec

VERIFIED FIXED in M5

Status

()

defect
P3
normal
VERIFIED FIXED
21 years ago
20 years ago

People

(Reporter: ian, Assigned: buster)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

21 years ago
The last sentence of CSS2 section 10.8.1, paragraph 2, says:

# (This applies to empty boxes as well, as if the empty box
# contained an infinitely narrow letter.)
     -- http://www.w3.org/TR/REC-CSS2/visudet.html#q22

NGLayout is ignoring empty inline elements instead.

See test one on the quoted test page:
  http://www.bath.ac.uk/%7Epy8ieh/internet/eviltests/emptyinline.html

Updated

21 years ago
Assignee: troy → kipp

Updated

21 years ago
Status: NEW → ASSIGNED

Comment 1

21 years ago
*** Bug 4359 has been marked as a duplicate of this bug. ***

Updated

21 years ago
Target Milestone: M6 → M5

Updated

21 years ago
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED

Comment 2

21 years ago
Fixed. Empty *inline* elements now work properly. There is no special hackery
for empty inline P's, however.

Updated

21 years ago
Status: RESOLVED → VERIFIED

Comment 3

21 years ago
Fixed in April 26th Win 32 Build.
You need to log in before you can comment on or make changes to this bug.