Leaks registering java plugin

RESOLVED INCOMPLETE

Status

()

Core
Plug-ins
RESOLVED INCOMPLETE
10 years ago
5 years ago

People

(Reporter: Andrew Schultz, Unassigned)

Tracking

({memory-leak})

Trunk
x86
Linux
memory-leak
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
Created attachment 311331 [details]
leak log

With current trunk, when I load a page with an <object> for the first time, I leak various objects if I have the java plugin installed.  When I load the page (the <object> here is just a simple html file), I also get:
###!!! ASSERTION: QueryInterface needed: 'query_result.get() == mRawPtr', file ../../../../dist/include/xpcom/nsCOMPtr.h, line 594

I only get the assertion if java is one of the plugins seamonkey finds.  I see the leak with the current Sun version of Java (6u5) and also the latest "Update N" release (6u10-b15)

Log with leaks attached.
(Reporter)

Comment 1

10 years ago
Created attachment 311506 [details]
stack for the assertion

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.