Closed Bug 424766 Opened 12 years ago Closed 12 years ago

[FIX]Left part of the page isn't repainted properly

Categories

(Core :: Web Painting, defect)

x86
All
defect
Not set

Tracking

()

VERIFIED FIXED

People

(Reporter: mats, Assigned: bzbarsky)

References

()

Details

(Keywords: regression)

Attachments

(4 files, 2 obsolete files)

STEPS TO REPRODUCE
1. load the URL (you should see a login page, enable cookies if you don't)

Try Reload a few times if the problem does not occur at once.

ACTUAL RESULT
Left part of the page isn't repainted properly, see attached screenshot.
Covering the window fixes it.

PLATFORMS AND BUILDS TESTED
Bug occurs in Firefox 2008032304 on MacOSX 10.5.2
Bug occurs in Firefox 2008032204 on Linux
Could not reproduce the problem using Firefox 2.0.0.11 on MacOSX 10.5.2
and Firefox 2.0.0.12 on Linux
Attached image Screenshot
I would love a 100% reproducible testcase.  Given one, I can try to fix this, but I just don't have time until late May to try to chase this down if it'll take significant debugging time.
Keywords: helpwanted, qawanted
Firefox crashes every time that the url is visited... Mac OS X, latest trunk build, fresh profile.
(the [Silverlight plugin] crash on the same URL is bug 424692)
Mats, does the patch in bug 424465 fix this?
Nope, still reproducible with that patch in Linux and MacOSX debug builds.
Hmm.  I managed to reproduce this exactly once on Linux...  I'm really going to need help with either making this more reproducible or smaller... :(
Attached file Testcase 1 (obsolete) —
Not exactly a small testcase, but at least it shows the issue more often than the URL.

You need to do a shift + reload to see the bug. Bug is visible 80% of them times doing this.

What causes the table to jump a bit is the image title of the "LDDR_westlaw_banner.jpg" image. Remove the title and it wont jump again.

I hope this testcase is enough/OK. If not I'll try to minimize it a bit more.
Attached file Testcase 2 (obsolete) —
Smaller testcase. Shift + reload to trigger issue.
Attachment #312235 - Attachment is obsolete: true
José, thanks!  That helped a lot.

This testcase should show the problem every time, independently of network conditions.  Looking into it now.
Assignee: nobody → bzbarsky
Attachment #312238 - Attachment is obsolete: true
Status: NEW → ASSIGNED
I could've sworn this code already looked like this... :(
Attachment #312667 - Flags: superreview?(roc)
Attachment #312667 - Flags: review?(roc)
Keywords: helpwanted, qawanted
Summary: Left part of the page isn't repainted properly → [FIX]Left part of the page isn't repainted properly
Attachment #312667 - Flags: superreview?(roc)
Attachment #312667 - Flags: superreview+
Attachment #312667 - Flags: review?(roc)
Attachment #312667 - Flags: review+
Comment on attachment 312667 [details] [diff] [review]
Fix
[Checkin: Comment 17]

Requesting approval.  Simple thinko fix.  Quite safe.
Attachment #312667 - Flags: approval1.9?
Flags: blocking1.9?
Comment on attachment 312667 [details] [diff] [review]
Fix
[Checkin: Comment 17]

has a reftest, I assume
Attachment #312667 - Flags: approval1.9? → approval1.9+
Flags: blocking1.9? → blocking1.9+
Reftests don't catch invalidation bugs. We don't have a test framework that can catch them, unfortunately. One is planned as part of post-1.9 work.
ok
Whiteboard: [reviewed patch in hand]
Checked in.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Flags: in-testsuite?
Resolution: --- → FIXED
Verified fixed with: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9pre) Gecko/2008040204 Minefield/3.0pre
Status: RESOLVED → VERIFIED
Depends on: 451332
Attachment #384715 - Flags: review?(roc)
Attachment #384715 - Attachment description: invalidate reftest → invalidate reftest (checkin-needed)
Attachment #312667 - Attachment description: Fix → Fix [Checkin: Comment 17]
Comment on attachment 384715 [details] [diff] [review]
invalidate reftest


http://hg.mozilla.org/mozilla-central/rev/544c0a55c402
Attachment #384715 - Attachment description: invalidate reftest (checkin-needed) → invalidate reftest (checkin-needed) [Checkin: Comment 20]
You may want to the test in 1.9.1 too...
Flags: in-testsuite? → in-testsuite+
Keywords: checkin-needed
Whiteboard: [reviewed patch in hand]
Keywords: checkin-needed
Whiteboard: checkin-needed-1.9.1
Attachment #384715 - Attachment description: invalidate reftest (checkin-needed) [Checkin: Comment 20] → invalidate reftest (checkin-needed to 1.9.1) [Checkin: Comment 20]
Attachment #384715 - Attachment description: invalidate reftest (checkin-needed to 1.9.1) [Checkin: Comment 20] → invalidate reftest
(In reply to comment #22)
> http://hg.mozilla.org/releases/mozilla-1.9.1/rev/004f430f1c70

Please, back out asap: this is timing out on both FF3.5 and SM2.0!
(In reply to comment #22)
> http://hg.mozilla.org/releases/mozilla-1.9.1/rev/004f430f1c70

backed out as well, because of this:

REFTEST TEST-UNEXPECTED-FAIL | file:///builds/moz2_slave/mozilla-1.9.1-macosx-unittest/build/layout/reftests/bugs/424766-1.html | timed out waiting for reftest-wait to be removed (after onload fired)
Hmm.  I thought we had MozReftestInvalidate on branch... roc, any idea what's up there?
I don't think we landed it on branch. It landed on trunk early this year, after we branched for 1.9.1.
Depends on: 761075
Component: Layout: View Rendering → Layout: Web Painting
You need to log in before you can comment on or make changes to this bug.