nsIFilePicker.filterApps more file extensions support

RESOLVED WONTFIX

Status

()

--
minor
RESOLVED WONTFIX
11 years ago
7 years ago

People

(Reporter: davide.ficano, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; it-IT; rv:1.8.1.11) Gecko/20071130 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; it-IT; rv:1.8.1.11) Gecko/20071130 Firefox/2.0.0.11

On Windows only *.exe and *.com are supported should be better if also *.bat and *.cmd appears


Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Where are you talking about?
(Reporter)

Comment 2

11 years ago
function showApplication() {
    var nsIFilePicker = Components.interfaces.nsIFilePicker;
    var fp = Components.classes["@mozilla.org/filepicker;1"]
            .createInstance(nsIFilePicker);
    fp.init(window, "Select a File", nsIFilePicker.modeOpen);
    fp.appendFilters(nsIFilePicker.filterApps);
}

Under Windows show only *.exe and *.com
but should show also *.bar and *.cmd

Updated

11 years ago
Component: OS Integration → Widget: Win32
Product: Firefox → Core
QA Contact: os.integration → win32

Comment 3

7 years ago
(In reply to comment #2)
> function showApplication() {
>     var nsIFilePicker = Components.interfaces.nsIFilePicker;
>     var fp = Components.classes["@mozilla.org/filepicker;1"]
>             .createInstance(nsIFilePicker);
>     fp.init(window, "Select a File", nsIFilePicker.modeOpen);
>     fp.appendFilters(nsIFilePicker.filterApps);
> }
> 
> Under Windows show only *.exe and *.com
> but should show also *.bar and *.cmd

.bar, AFAICT, is associated with either dbase or the game "Age of Mythology", so that certainly shouldn't be included. .cmd is debatable since batch scripts accept command line args but I don't think we want those showing up in most of our uses of this filter. Resolving won't fix for now, if you feel strongly about this feel free to post a counter argument.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.