Saved Search pane on tags often shows messages that don't match up with search results

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
RESOLVED WORKSFORME
10 years ago
4 years ago

People

(Reporter: G G, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2010-05-12)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: version 2.0.0.12 (20080213)

I have been using the tags functionality in thunderbird to categorize my emails.  I have created saved searches such as "tags contains Later", etc.  When clicking on the search, I get my 25 or so matching items (expected).  However, going through them (by double clicking in the results pane) I notice that every so often I will get a window displaying an email that does not correspond to what I double-clicked on, i.e, you double-clicked on message C and a window popped up showing message B (unexpected).  This is a POP account, but I've noticed the same thing under IMAP.  Tried compacting the folder, same result.  Verified this on a couple machines also.   

Reproducible: Always

Steps to Reproduce:
1.  Create a saved search that has "Tags contains later"
2.  Send about 20 very short emails to the account, with subjects like "[A]","[B]"....."[T]"
3.  In Thunderbird, retrive the 20 emails and tag them with "Later" by using the number 5.
4.  Click on the saved search set up in part 1, it should show you the 20 messages that you just tagged 'later'.
5.  Begin going through the 20 mails by double-clicking on them.  Be sure to note that when you click on email [A] that in fact the [A] email is shown.  
Actual Results:  
My experience is that after going through several of them I have one (say [G]), that shows me an email for [C].  

Expected Results:  
I was expecting the message I clicked on to be displayed in all cases.

Comment 1

10 years ago
Created attachment 312690 [details]
Folder with 20 tagged messages

It works for me in Thunderbird 3:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008032902 Thunderbird/3.0a1pre

If it did ever happen to me, I would try the Rebuild Index button in the properties of the folder where the messages are stored.

Comment 2

10 years ago
does it have something to do with refresh issue on bug 365392?
Reporter what you think about comment #1: it is a dupe of  bug #365392?

Could you try to see if it still happens with
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-1.9.1/ ?

Updated

8 years ago
Whiteboard: closeme 2010-05-12
RESOLVED INCOMPLETE due to lack of response to previous comment. If you feel this change was made in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 5

8 years ago
My apologies for completely going AWOL on this one.  I was able to reproduce it regularly under TB 2 circa the reporting time frame (fyi rebuilding indexes did not help), but since upgrading to 3, I have not seen a re-occurrence.  If I see anything like this again, I'll put it under TB 3.  In other words, I'm fine with closing this.
Resolution: INCOMPLETE → FIXED
WFM: FIXED is only for bugs where the actual cause of the fix is known.
Resolution: FIXED → WORKSFORME

Comment 7

4 years ago
FWIW, I have setup a few saved searches in Icedove 17.0.10 from Debian, and haven't used them seriously yet, but sometimes when I look into one of them, there is a new couple of non-matching messages.  After I view them, they disappear from the saved search (there are no "read" search criteria).
You need to log in before you can comment on or make changes to this bug.