Random item focused if mouse is in the location bar area

RESOLVED DUPLICATE of bug 420804

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 420804
10 years ago
10 years ago

People

(Reporter: Ivan N. Zlatev, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4) Gecko/2008030800 SUSE/2.9.94-4.2 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4) Gecko/2008030800 SUSE/2.9.94-4.2 Firefox/3.0b4

The new location bar has a relatively big size and almost always the mouse is in it's area. This is a problem if the user uses Ctrl+L to focus the address bar and start typing. The location bar will show the list of matches, but because the mouse cursor is in the area the item under the mouse cursor will get selected. This is a problem as the user can no longer just hit ENTER for the best match, because a random item has been selected.

My proposal is that if the mouse is initially in the area of the search results the focus should not be set to the item under the cursor as this is not what the user intends.

Check the attached screenshots for an example of what I am trying to describe.

Reproducible: Always

Steps to Reproduce:
1. Put the mouse in the upper part of you FF window
2. Ctrl+L
3. Start typing
Actual Results:  
The item under the mouse item will get focus

Expected Results:  
No item has focus
(Reporter)

Comment 1

10 years ago
Created attachment 311471 [details]
Screenshot #1
(Reporter)

Comment 2

10 years ago
Created attachment 311472 [details]
Screenshot #2
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 420804
You need to log in before you can comment on or make changes to this bug.