Cannot choose a previous statement in www.americanexpress.com

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Pattrawoot Suesatayasilp, Unassigned)

Tracking

3.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4

Firefox 3 Beta cannot display 

Reproducible: Always

Steps to Reproduce:
1. Login to americanexpress.com
2. Click on "Manage Your Account" link
3. Choose a credit card to view recent activity
4. Click on "Recent Activity" link
5. Try to change Time Period to any previous Statements. You will find that you are unable to choose any previous statements to view. (Once you click on Previous Statements, a list of previous statements is expected to be shown)
Actual Results:  
Nothing happens when clicking on Previous Statements.

Expected Results:  
A list of previous statements is expected to be shown, after clicking on Previous Statements
(Reporter)

Updated

10 years ago
Summary: Cannot choose a previous statement → Cannot choose a previous statement in www.americanexpress.com

Comment 1

10 years ago
They are using CSS to simulate a drop down box and it appears that the onclick event is not firing.

<div class="viewActBox" name="maintimeperiod" id="maintimeperiod">
   <span class="viewAct_text">Time Period:</span>
   <div  name="time" id="time" class="ViewAct-subbox" onclick="DisplayTimePeriodValues('timeperioddropdown','time')">
      <div id="TB" class="ViewAct-txtbox2a" >Recent Activity</div> 
      <div class="ViewAct-imga" style=" "><img src="/shared/images/en_US/estmt/img_bluearrow_dropdown.gif" alt="" style="margin:2px;" /></div>
      <div id="TC" class="ViewAct-txtbox2a" style="float:right;FONT-WEIGHT: normal; FONT-SIZE: 11px;COLOR: black;"> Mar 5, 2008 to Present</div>
   </div>
</div> <!--Time Period-->

This happens with the OS X version of FF as well.  Works fine in 2.x release.

Comment 2

10 years ago
I can confirm this as well.  Works fine in FF2 & Opera, but FF3 (even newest nightly) doesn't work on, Windows or Linux (haven't tested Mac).

Updated

10 years ago
Duplicate of this bug: 434195

Comment 4

10 years ago
Still broken in RC1 on OS-X.

Updated

10 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

10 years ago
Created attachment 324250 [details]
amex.png

Updated

10 years ago
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → 3.0 Branch

Comment 6

10 years ago
Looks like this got fixed between the final release candidate and the actual release.

Comment 7

10 years ago
My apologies, I spoke too soon.  Parts of this drop down are working but not the whole thing.

Comment 8

10 years ago
I am still experiencing the same issue. I can confirm that it's broken in Windows, OSX and Linux (CentOS 5). 

Let me know if you would like screenshots of the problem.

Comment 9

10 years ago
Hmmm...So I'm not seeing this behavior on the current site.  I'm on OS X.  I tried it with the latest build of Firefox 3.1 and with the 3.01 release build of Firefox.

--> WFM on both.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1a2pre) Gecko/20080825074258 Minefield/3.1a2pre

Build identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1

Comment 10

10 years ago
I confirm that 3.0.1 in OSX seems to be working just fine in relation to this problem.

Comment 11

10 years ago
it seems either the mozilla people fixed the issue, or amex did because it is now working for me with 3.0.1 under kubuntu 8.04.1.  at any rate, i also ran my vm of XP Pro, and 3.0.1 also works fine, which it previously did not.  i have a feeling american express changed how it was rendered!

Comment 12

10 years ago
Also works in trunk on WinXP

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2pre) 
Gecko/20080828034823 Minefield/3.1a2pre

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.2pre) 
Gecko/2008080105 GranParadiso/3.0.2pre

Comment 13

10 years ago
It indeed does work now!

 Amex must have changed something. I have been on 3.01 and have regularly checked for a fix. Still on 3.01 and the drop downs appear.

Comment 14

10 years ago
I have a feeling it was amex, since I can't think of any changes that would have solved this.  Going to mark it as WFM.  Thanks for all the reporting, folks.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.