class nsDocLoaderImpl leaks when browsing about:blank and closing window

VERIFIED DUPLICATE of bug 44230

Status

()

P3
normal
VERIFIED DUPLICATE of bug 44230
19 years ago
18 years ago

People

(Reporter: inaky.gonzalez, Assigned: mscott)

Tracking

({memory-leak})

Trunk
x86
Linux
memory-leak
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
When loading with about:blank, I get three instances of nsDocLoaderImpl leaking.
Tried to trace the first one of them but got no luck of which could be the
cause. The other two instances create really complicated trees, so I´m moving up
in the hierarchy to try to search to a possible parent/owner class which is also
leaking.


Reproducible: Always
Steps to Reproduce:
1../mozilla about:blank
2.Quit closing the window without moving the mouse over the lizard window
(Reporter)

Updated

19 years ago
Keywords: mlk

Comment 1

19 years ago
Either mscott or rpotts should get this. Trying mscott first...
Assignee: gagan → mscott
(Reporter)

Comment 2

19 years ago
I'm starting to be pretty confident this leak is caused by nsEventQueueImpl 
leaking one instance. I'm looking at that, as almost all the classes which 
could be hanging around nsDocLoaderImpl were haivng a nsEventQueueImpl around. 

Comment 3

19 years ago
I thought pav fixed all the nsEventQueueImpl leaks? Have they come back?
(Reporter)

Comment 4

19 years ago
Created attachment 10657 [details] [diff] [review]
Fix using atexit(). See comments on the bug log
(Reporter)

Comment 5

19 years ago
Forget that attachment, my navigator went ballistic and posted it to another bug
report, sorry.
(Reporter)

Comment 6

19 years ago
Ok, this bug seems to be fired as for #44230, so I´m marking it as a duplicate.


*** This bug has been marked as a duplicate of 44230 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 7

18 years ago
verif. DUP
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.