Page gets covered by a grey plane

RESOLVED INVALID

Status

()

Core
Layout
P3
normal
RESOLVED INVALID
18 years ago
18 years ago

People

(Reporter: Stephan Niemz, Assigned: clayton)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
The above page is almost unreadable, because most of it is covered by a
grey plane. This bug is best visible after resizing the window, and you can
see some parts of the page again after scrolling, but not everything and
not always.

    There are other pages where I've seen this and I'll add them when I see
them again.

    It only happens with GFX scrollbars, not with native scrollbars.
Perhaps this bug should be added to the dependencies of bug 38639, but I'm
not sure.

    I'm running my home-built non-debug, optimized Mozilla from a today's
checkout.

Comment 1

18 years ago
Sounds like bug #42115; I'm not seeing it here. Are you building from an M16
checkout?

Comment 2

18 years ago
Works for me on Linux build 2000061314.

Comment 3

18 years ago
marking WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

18 years ago
Created attachment 10175 [details]
Screenshot from Mozilla (not really) showing that URL
(Reporter)

Comment 5

18 years ago
    There has been no change after another checkout and build today, so I'm
reopening this bug.

    Maybe it's a duplicate of bug 42115, but I'm not sure. I get a similar
effect on the page

http://www.bath.ac.uk/%7Epy8ieh/internet/eviltests/htmlbodyrendering7.html

    mentioned there, but it's not the same. On that page, scrolling with the
mouse wheel doesn't work, but but it reveals most of the content of the
page, where scrolling by dragging the scrollbars hides it again (almost
everything). I can provide screenshots if that helps.

    This time, it also doesn't work with native scrollbars, although the
effects are different. Most of the page is visible, but the mouse wheel
still doesn't work there. On other pages it works fine.

    I did the checkout as described on your web pages (cvs co client.mk;
make -f client.mk), so it should be the current version.

    I'm using Gnome and Enlightenment on Linux 2.2.14, if that matters.
Maybe it's a problem with the window manager since you can't reproduce it?
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 6

18 years ago
I still can't reproduce, unfortunately (061608). Can you try this nightly build,
to verify if it's an environment problem or if it's the build?
If you think E might beto blame, try it under twm.
(Reporter)

Comment 7

18 years ago
    Okay, I've downloaded the latest nightly build (061808) over my slow ISDN
line, and installed twm, but with both I can still reproduce this - sorry.
I could provide a screenshot if that helps.
My guess is that you have the "Use viewmanager2" in Advanced prefs unchecked.  
This is checked by default.  Is this the problem?

I'd like to get this pref removed if it was...
(Reporter)

Comment 9

18 years ago
    You're right, "Use viewmanager2" in the Debug prefs was unchecked. But
I can't remember changing it, so maybe it wasn't always the default?

    Anyway, this helped, thanks! Although it seems to introduce new
bug(s). I've just filed one as bug 43031.

Comment 10

18 years ago
2000061820/Linux crashed when I tried to view the above page.

Comment 11

18 years ago
resolving as invalid since reporter was using old viewmanager and we don't need 
to fix bugs that occur as a result of it anymore...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.