Envelope parsing problem: Mail with "Henrik "The man" Gemal" <gemal@dk.net> in From crashes IMAP

VERIFIED INVALID

Status

MailNews Core
Networking: IMAP
P3
critical
VERIFIED INVALID
18 years ago
10 years ago

People

(Reporter: Henrik Gemal, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+] ETA 6/17)

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
If you try to read a folder with a mail that has the following header:
"Henrik "The man" Gemal" <gemal@dk.net>
you IMAP fetching will crash with INBOX:PARSER:Internal Syntax Error.

Build 2000061320 on Win2K
(Reporter)

Comment 1

18 years ago
Created attachment 10120 [details]
Uhadada mail that breakes mozilla IMAP parser...
(Reporter)

Comment 2

18 years ago
Created attachment 10121 [details]
IMAP log with "INBOX:PARSER:Internal Syntax Error"

Comment 3

18 years ago
hmm looks like another envelope parsing problem. This should be easy to catch
since you gave us the mail message that triggers it. thanks gemal.
Keywords: crash, nsbeta2

Updated

18 years ago
Target Milestone: --- → M17
(Reporter)

Comment 4

18 years ago
mscott@netscape.com:
perhaps there could be someway to show these errors to the user?
Sometimes it's very hard to find out that it's the IMAP parser since mozilla 
mail just stops working. Or perhaps just print an error to the console?

Updated

18 years ago
Summary: Mail with "Henrik "The man" Gemal" <gemal@dk.net> in From crashes IMAP → Envelope parsing problem: Mail with "Henrik "The man" Gemal" <gemal@dk.net> in From crashes IMAP
(Assignee)

Comment 5

18 years ago
may be the same as my other envelope bug. Taking.
Assignee: mscott → bienvenu

Comment 6

18 years ago
Putting on [nsbeta2+] radar for beta2 fix. 
Whiteboard: [nsbeta2+]
(Assignee)

Comment 7

18 years ago
does the client really crash, or just get a parser error? I'm not able to
reproduce a parser error, but I am able to sometimes crash on messages like
this. I have a fix for the crash, which might fix the parser error too. I'll try
to get it checked in before tomorrow's build
Status: NEW → ASSIGNED
Whiteboard: [nsbeta2+] → [nsbeta2+] ETA 6/17
(Reporter)

Comment 8

18 years ago
It doesn't crash the browser, I'm just getting a parser error in the IMAP log. 
The problem is that when you get parser errors like this it seems to disable 
furthere mail retrieving.
(Assignee)

Comment 9

18 years ago
ah, the word "crash" threw me off. Could you try again with the build from today 
(6/16) when it comes out?
(Assignee)

Comment 10

18 years ago
I tried your message on a UW server, and didn't have a problem, so I'm marking 
it fixed. Please reopen if today's build doesn't work for you.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 11

18 years ago
Still getting the parser crash in 2000061608. Please note not browser crash.
1124[2503d28]: fep2.sprawl.dk:S-INBOX:CreateNewLineFromSocket: * 120 FETCH (UID 
1131 RFC822.SIZE 500 FLAGS () ENVELOPE ("Wed, 14 Jun 2000 19:44:51 +0200" "from 
test " (("Henrik " The man " Gemal" N
1124[2503d28]: fep2.sprawl.dk:S-INBOX:STREAM:OPEN Size: 500: Begin Message 
Download Stream
1124[2503d28]: fep2.sprawl.dk:S-INBOX:PARSER:Internal Syntax Error: %s: * 120 
FETCH (UID 1131 RFC822.SIZE 500 FLAGS () ENVELOPE ("Wed, 14 Jun 2000 19:44:51 
+0200" "from test " (("Henrik " The man "
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 12

18 years ago
what kind of imap server are you using? The log doesn't contain the server 
greeting, so I can't tell. For some reason, I thought you were using UW, but I 
don't know why I thought that.

Comment 13

18 years ago
I believe Henrik uses an Exchange server
(Assignee)

Comment 14

18 years ago
you're kidding, right? Argh. Do we have one of those in house?
(Reporter)

Comment 15

18 years ago
Created attachment 10265 [details]
Full IMAP log (software.com IMAP server)
(Assignee)

Comment 16

18 years ago
unfortunately, the log, thanks to a PRLOG limitation, is cut off before I can
see the interesting part. Lisa or Karen, do we have a "Software.com" IMAP server?

Comment 17

18 years ago
I don't believe we do.  :-(
I found http://www.software.com/products/software.html, but I can't tell if this 
is an IMAP mail server or not.  Henrik - do you know of any test account that 
David can try?
(Assignee)

Comment 18

18 years ago
John, the software.com imap server is returning an envelope that looks like this 
when the From user name is "Henrik "the man" Gemal". Both UW and our 4.0 server 
just strip out the quotes around "the man". If the software.com server wants to 
maintain the quotes, doesn't it need to escape them? Here's the log of what it 
returns:

ENVELOPE ("Wed, 14 Jun 2000 19:44:51 +0200" "from test " (("Henrik " The man " 
Gemal" NI

Comment 19

18 years ago
Scott, isn't this problem is the problem you fix in MailConnect6? Or this is 
another problem....
(Assignee)

Comment 20

18 years ago
so, to summarize for the PDT, this *looks* like a server bug.
Keywords: crash

Comment 21

18 years ago
Yes, if the software.com server wants to preserve the quotes, it has to 
either escape them or send the subject as a literal.  The server is violating 
the IMAP protocol.
(Assignee)

Comment 22

18 years ago
thanks, John.

Henrik, do you have any contact info for the server vendor to report this bug? 
I'm going to mark this invalid and open a new bug to add a client preference for 
turning off the envelope command.
(Assignee)

Comment 23

18 years ago
marking invalid
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → INVALID
(Reporter)

Comment 24

18 years ago
Perhaps:
http://www.software.com/supportresources/imwebsupport.html

Will investigate....

Comment 25

18 years ago
Thanks. John.
Based on John's comment, marking as verified.
Henrik, thanks for testing this, if after your investigation, you don't 
agree....you still can reopen later.
Status: RESOLVED → VERIFIED

Comment 26

18 years ago
I suggest bienvenu try to contact the vendor through the imc-mailconnect@imc.org 
mailing list.
(Assignee)

Comment 27

18 years ago
I think a personal visit would be much more productive :-)
(Assignee)

Comment 28

18 years ago
too bad mail to that address bounces :-(

Comment 29

18 years ago
You probably have to subscribe first.  Send a message to 
imc-mailconnect-request@imc.org with the word "subscribe" in the body.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.