Import of Safari 3.0/3.1 Bookmarks Fails For Bookmarks/Folders with Unusual Unicode Chars in Name

RESOLVED DUPLICATE of bug 417264

Status

()

Firefox
Bookmarks & History
--
critical
RESOLVED DUPLICATE of bug 417264
10 years ago
10 years ago

People

(Reporter: Daryl Forrest, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b4) Gecko/2008030317 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b4) Gecko/2008030317 Firefox/3.0b4

In Safari, I have a number of bookmarks or bookmark folders with names consisting of or including unusual Unicode characters such as the star ('★'), the apple (''), the writing hand ('✍'), the infinity symbol ('∞'), and the ellipsis ('…'), among others.

When importing bookmarks from Safari, and bookmarks or bookmark folders (and their contents) containing these characters are simply not imported. Bookmarks or bookmarks folders with regular ASCII names are imported fine. No warnings or errors are reported.

Reproducible: Always

Steps to Reproduce:
1. Import a Safari bookmarks file containing bookmarks or bookmark folder with
   "problem" characters (see "Details" above).
Actual Results:  
The import appears to complete without any problems, but all bookmarks or bookmark folders (and their contents) with "problem" characters were not imported.

Expected Results:  
The import should have correctly imported the bookmarks and bookmark folders (and their contents) with "problem" characters.

If I rename an existing bookmark to hold one of these "problem" characters, it works file. The name with the "problem" character displays and functions correctly, so the problem appears to be isolated to the bookmarks import routine.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 417264
You need to log in before you can comment on or make changes to this bug.