bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Review submission is sometimes broken:

RESOLVED FIXED in 3.2

Status

addons.mozilla.org Graveyard
Public Pages
--
major
RESOLVED FIXED
10 years ago
3 years ago

People

(Reporter: clouserw, Assigned: wenzel)

Tracking

Details

(Reporter)

Description

10 years ago
Seems to only happen on this one add-on for me so far.  To reproduce:

1) Login (and hope you stay that way)
2) Load https://preview.addons.mozilla.org/en-US/firefox/addon/2731
3) Fill in a review and a rating
4) Click submit, see "There are errors in this form. Please correct them and resubmit."

If I do the same thing on my dev copy, I see at the top:

Query: INSERT INTO `reviews` (`id`,`title`,`rating`,`body`,`version_id`,`user_id`,`editorreview`,`created`,`modified`) VALUES ('',107968,3,107969,0,10482,1,'2008-03-25 14:32:56','2008-03-25 14:32:56')
Warning: SQL Error: 1452: Cannot add or update a child row: a foreign key constraint fails (`c_remora/reviews`, CONSTRAINT `reviews_ibfk_1` FOREIGN KEY (`version_id`) REFERENCES `versions` (`id`)) in /home/clouserw/public_html/remora/site/cake/libs/model/datasources/dbo_source.php on line 440
(Assignee)

Comment 1

10 years ago
Looks like the new review box does not honor if somebody has already written a review before.
Assignee: nobody → fwenzel
(Assignee)

Comment 2

10 years ago
Actually, I was wrong, it doesn't have anything to do with an existing review. It wasn't possible to submit reviews for sandboxed add-ons unless you had "show experimental" activated, but we removed this restriction, so I nuked it in the reviews controller too now.

Fixed in r11601.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.